summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/json-glib/json-glib_1.4.4.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2019-01-09 15:19:43 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-11 10:39:09 +0000
commit9c8b3aa20618e60bd1ec2ad369e8f4781a645972 (patch)
tree975ccaf1248bd047566fd5666fb5ace99b4a5051 /meta/recipes-gnome/json-glib/json-glib_1.4.4.bb
parente60fee502ed97554b94a9b655574c92e943e28c6 (diff)
downloadpoky-9c8b3aa20618e60bd1ec2ad369e8f4781a645972.tar.gz
json-glib: upgrade 1.4.2 -> 1.4.4
Add PACKAGECONFIG[manpages] for generating man pages. (From OE-Core rev: 078b2389a76ca3eba2307c7aa20be095cf96e060) Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/json-glib/json-glib_1.4.4.bb')
-rw-r--r--meta/recipes-gnome/json-glib/json-glib_1.4.4.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-gnome/json-glib/json-glib_1.4.4.bb b/meta/recipes-gnome/json-glib/json-glib_1.4.4.bb
new file mode 100644
index 0000000000..95f90569de
--- /dev/null
+++ b/meta/recipes-gnome/json-glib/json-glib_1.4.4.bb
@@ -0,0 +1,44 @@
1SUMMARY = "JSON-GLib implements a full JSON parser using GLib and GObject"
2DESCRIPTION = "Use JSON-GLib it is possible to parse and generate valid JSON\
3 data structures, using a DOM-like API. JSON-GLib also offers GObject \
4integration, providing the ability to serialize and deserialize GObject \
5instances to and from JSON data types."
6HOMEPAGE = "http://live.gnome.org/JsonGlib"
7
8LICENSE = "LGPLv2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
10
11DEPENDS = "glib-2.0"
12
13GNOMEBASEBUILDCLASS = "meson"
14inherit gnomebase lib_package gobject-introspection gtk-doc gettext ptest-gnome manpages
15
16SRC_URI += "file://run-ptest"
17SRC_URI[archive.md5sum] = "4d4bb9837f6d31e32d0ce658ae135f68"
18SRC_URI[archive.sha256sum] = "720c5f4379513dc11fd97dc75336eb0c0d3338c53128044d9fabec4374f4bc47"
19
20PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native xmlto-native"
21
22# This builds both API docs (via gtk-doc)
23GTKDOC_ENABLE_FLAG = "-Ddocs=true"
24GTKDOC_DISABLE_FLAG = "-Ddocs=false"
25
26GI_ENABLE_FLAG = "-Dintrospection=true"
27GI_DISABLE_FLAG = "-Dintrospection=false"
28
29EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '${GTKDOC_ENABLE_FLAG}', \
30 '${GTKDOC_DISABLE_FLAG}', d)} "
31EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '${GI_ENABLE_FLAG}', \
32 '${GI_DISABLE_FLAG}', d)} "
33
34do_install_append() {
35 if ! ${@bb.utils.contains('PTEST_ENABLED', '1', 'true', 'false', d)}; then
36 rm -rf ${D}${datadir}/installed-tests ${D}${libexecdir}
37 fi
38}
39
40BBCLASSEXTEND = "native nativesdk"
41
42# Currently it's not possible to disable gettext in Meson, so we need to force
43# this back on.
44USE_NLS_class-native = "yes"