summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gtk-doc/gtk-doc_1.28.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2018-04-04 14:13:12 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 13:28:02 +0100
commitf367f31e9444e02e65f352cd8780fe7c71deaa1f (patch)
tree0846b4254f08569c5706fcec120dc37653c36468 /meta/recipes-gnome/gtk-doc/gtk-doc_1.28.bb
parent531946c1365c9de3895751252893f1b73a280e1e (diff)
downloadpoky-f367f31e9444e02e65f352cd8780fe7c71deaa1f.tar.gz
gtk-doc: update to 1.28
(From OE-Core rev: 22cc8b49e31a121ab48d3ebaae5d0ccfaa4053fa) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/gtk-doc/gtk-doc_1.28.bb')
-rw-r--r--meta/recipes-gnome/gtk-doc/gtk-doc_1.28.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gtk-doc/gtk-doc_1.28.bb b/meta/recipes-gnome/gtk-doc/gtk-doc_1.28.bb
new file mode 100644
index 0000000000..a2ec6ac78f
--- /dev/null
+++ b/meta/recipes-gnome/gtk-doc/gtk-doc_1.28.bb
@@ -0,0 +1,50 @@
1SUMMARY = "Documentation generator for glib-based software"
2DESCRIPTION = "Gtk-doc is a set of scripts that extract specially formatted comments \
3 from glib-based software and produce a set of html documentation files from them"
4HOMEPAGE = "http://www.gtk.org/gtk-doc/"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8inherit gnomebase
9
10# Configure the scripts correctly (and build their dependencies) only if they are actually
11# going to be used; otheriwse we need only the m4/makefile includes from the gtk-doc tarball.
12PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "api-documentation", "working-scripts", "", d)}"
13
14# This will cause target gtk-doc to hardcode paths of native dependencies
15# into its scripts. This means that target gtk-doc package is broken;
16# hopefully no one minds because its scripts are not used for anything during build
17# and shouldn't be used on targets.
18PACKAGECONFIG[working-scripts] = "--with-highlight=source-highlight,--with-highlight=no,libxslt-native xmlto-native source-highlight-native python3-six"
19PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,glib-2.0"
20
21SRC_URI[archive.md5sum] = "48550c33f9b9b530f9e5f397979b613a"
22SRC_URI[archive.sha256sum] = "911e29e302252c96128965ee1f4067d5431a88e00ad1023a8bc1d6b922af5715"
23SRC_URI += "file://0001-Do-not-hardocode-paths-to-perl-python-in-scripts.patch \
24 file://0001-Do-not-error-out-if-xsltproc-is-not-found.patch \
25 file://conditionaltests.patch \
26 file://no-clobber.patch \
27 "
28SRC_URI_append_class-native = " file://pkg-config-native.patch"
29
30BBCLASSEXTEND = "native nativesdk"
31
32# Do not check for XML catalogs when building because that
33# information is not used for anything during build. Recipe
34# dependencies make sure we have all the right bits.
35do_configure_prepend() {
36 sed -i -e 's,^JH_CHECK_XML_CATALOG.*,,' ${S}/configure.ac
37}
38
39FILES_${PN} += "${datadir}/sgml"
40FILES_${PN}-dev += "${libdir}/cmake"
41FILES_${PN}-doc = ""
42
43SYSROOT_PREPROCESS_FUNCS_append_class-native = " gtkdoc_makefiles_sysroot_preprocess"
44gtkdoc_makefiles_sysroot_preprocess() {
45 # Patch the gtk-doc makefiles so that the qemu wrapper is used to run transient binaries
46 # instead of libtool wrapper or running them directly
47 sed -i \
48 -e "s|GTKDOC_RUN =.*|GTKDOC_RUN = \$(top_builddir)/gtkdoc-qemuwrapper|" \
49 ${SYSROOT_DESTDIR}${datadir}/gtk-doc/data/gtk-doc*make
50}