diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2025-01-07 17:01:11 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2025-01-09 15:26:50 +0000 |
commit | e9f8d0e547b9fe593f7447a6c9845ffa39de7df1 (patch) | |
tree | 89fefef8afa94a514074df1b21a62b5b4cc1c74f /meta/recipes-gnome/gtk+/gtk4_4.16.12.bb | |
parent | a97a9cd74b2e61075f26762221ba587f834504cc (diff) | |
download | poky-e9f8d0e547b9fe593f7447a6c9845ffa39de7df1.tar.gz |
gtk4: upgrade 4.16.7 -> 4.16.12
Changelog:
==========
* GtkFileChooser:
- Fix a focus problem with the server entry
* GtkEmojiChooser:
- Update to CLDR 46 / Unicode 16
* GtkAboutDialog:
- Small improvements
* Wayland:
- Fix some Vulkan sizing corner cases
- Fix problems with rotated, offloaded images
- Fix a few crashes
* Demos:
- Don't create extra windows for D-Bus activation
(From OE-Core rev: ed161f0a0cbcef50c43820d58989e5a020763dbf)
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/gtk+/gtk4_4.16.12.bb')
-rw-r--r-- | meta/recipes-gnome/gtk+/gtk4_4.16.12.bb | 135 |
1 files changed, 135 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gtk+/gtk4_4.16.12.bb b/meta/recipes-gnome/gtk+/gtk4_4.16.12.bb new file mode 100644 index 0000000000..d8d37a526d --- /dev/null +++ b/meta/recipes-gnome/gtk+/gtk4_4.16.12.bb | |||
@@ -0,0 +1,135 @@ | |||
1 | SUMMARY = "Multi-platform toolkit for creating GUIs" | ||
2 | DESCRIPTION = "GTK is a multi-platform toolkit for creating graphical user interfaces. Offering a complete \ | ||
3 | set of widgets, GTK is suitable for projects ranging from small one-off projects to complete application suites." | ||
4 | HOMEPAGE = "http://www.gtk.org" | ||
5 | BUGTRACKER = "https://bugzilla.gnome.org/" | ||
6 | SECTION = "libs" | ||
7 | |||
8 | DEPENDS = " \ | ||
9 | atk \ | ||
10 | cairo \ | ||
11 | fribidi \ | ||
12 | gdk-pixbuf \ | ||
13 | gdk-pixbuf-native \ | ||
14 | glib-2.0 \ | ||
15 | graphene \ | ||
16 | harfbuzz \ | ||
17 | jpeg \ | ||
18 | libdrm \ | ||
19 | libepoxy \ | ||
20 | libpng \ | ||
21 | librsvg \ | ||
22 | libxkbcommon \ | ||
23 | pango \ | ||
24 | python3-docutils-native \ | ||
25 | tiff \ | ||
26 | " | ||
27 | |||
28 | LICENSE = "LGPL-2.0-only & LGPL-2.0-or-later & LGPL-2.1-or-later" | ||
29 | LIC_FILES_CHKSUM = " \ | ||
30 | file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ | ||
31 | file://gtk/gtk.h;endline=25;md5=61900d77e8d5bc67cf15ad93de9a3490 \ | ||
32 | file://gdk/gdk.h;endline=25;md5=a0fb26c1f6b94e66d148279e192c333f \ | ||
33 | file://tests/testgtk.c;endline=25;md5=49d06770681b8322466b52ed19d29fb2 \ | ||
34 | " | ||
35 | |||
36 | MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}" | ||
37 | |||
38 | UPSTREAM_CHECK_REGEX = "gtk-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)\.tar.xz" | ||
39 | |||
40 | SRC_URI = "http://ftp.gnome.org/pub/gnome/sources/gtk/${MAJ_VER}/gtk-${PV}.tar.xz" | ||
41 | SRC_URI[sha256sum] = "ef31bdbd6f082c4401634a20c850b0050c9bf252ef1e079764ee95a2a0c4c95a" | ||
42 | |||
43 | S = "${WORKDIR}/gtk-${PV}" | ||
44 | |||
45 | CVE_PRODUCT = "gnome:gtk" | ||
46 | |||
47 | inherit meson gettext pkgconfig gi-docgen update-alternatives gsettings features_check gobject-introspection | ||
48 | |||
49 | # TBD: nativesdk | ||
50 | # gobject-introspection.bbclass pins introspection off for nativesk. As long as | ||
51 | # we do not remove this wisdom or hack gtk4, it is not possible to build | ||
52 | # nativesdk-gtk4 | ||
53 | BBCLASSEXTEND = "native" | ||
54 | |||
55 | GSETTINGS_PACKAGE:class-native = "" | ||
56 | |||
57 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" | ||
58 | REQUIRED_DISTRO_FEATURES = "opengl" | ||
59 | GIDOCGEN_MESON_OPTION = "documentation" | ||
60 | GIR_MESON_ENABLE_FLAG = 'enabled' | ||
61 | GIR_MESON_DISABLE_FLAG = 'disabled' | ||
62 | |||
63 | EXTRA_OEMESON = " -Dbuild-tests=false -Dbuild-testsuite=false -Dbuild-demos=false" | ||
64 | |||
65 | PACKAGECONFIG ??= "gstreamer ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11 vulkan', d)}" | ||
66 | PACKAGECONFIG:class-native = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" | ||
67 | PACKAGECONFIG:class-nativesdk = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" | ||
68 | |||
69 | PACKAGECONFIG[x11] = "-Dx11-backend=true,-Dx11-backend=false,at-spi2-atk fontconfig libx11 libxext libxcursor libxi libxdamage libxrandr libxrender libxcomposite libxfixes xinerama" | ||
70 | PACKAGECONFIG[wayland] = "-Dwayland-backend=true,-Dwayland-backend=false,wayland wayland-protocols virtual/egl virtual/libgles2 wayland-native" | ||
71 | PACKAGECONFIG[cloudproviders] = "-Dcloudproviders=enabled,-Dcloudproviders=disabled,libcloudproviders" | ||
72 | PACKAGECONFIG[cups] = "-Dprint-cups=enabled,-Dprint-cups=disabled,cups,cups gtk4-printbackend-cups" | ||
73 | PACKAGECONFIG[colord] = "-Dcolord=enabled,-Dcolord=disabled,colord" | ||
74 | PACKAGECONFIG[iso-codes] = ",,iso-codes,iso-codes" | ||
75 | # gtk4 wants gstreamer-player-1.0 -> gstreamer1.0-plugins-bad | ||
76 | PACKAGECONFIG[gstreamer] = "-Dmedia-gstreamer=enabled,-Dmedia-gstreamer=disabled,gstreamer1.0-plugins-bad" | ||
77 | PACKAGECONFIG[tracker] = "-Dtracker=enabled,-Dtracker=disabled,tinysparql,localsearch" | ||
78 | PACKAGECONFIG[vulkan] = "-Dvulkan=enabled,-Dvulkan=disabled, vulkan-loader vulkan-headers shaderc-native" | ||
79 | |||
80 | # Disable int-conversion warning as error until [1] is fixed | ||
81 | # [1] https://gitlab.gnome.org/GNOME/gtk/-/issues/6033 | ||
82 | CFLAGS += "-Wno-error=int-conversion" | ||
83 | |||
84 | LIBV = "4.0.0" | ||
85 | |||
86 | FILES:${PN}:append = " \ | ||
87 | ${datadir}/glib-2.0/schemas/ \ | ||
88 | ${datadir}/gtk-4.0/emoji/ \ | ||
89 | ${datadir}/metainfo/ \ | ||
90 | ${datadir}/icons/hicolor/*/apps/org.gtk.PrintEditor4*.* \ | ||
91 | ${libdir}/gtk-4.0/${LIBV}/media \ | ||
92 | ${bindir}/gtk4-update-icon-cache \ | ||
93 | ${bindir}/gtk4-launch \ | ||
94 | " | ||
95 | |||
96 | FILES:${PN}-dev += " \ | ||
97 | ${datadir}/gtk-4.0/gtk4builder.rng \ | ||
98 | ${datadir}/gtk-4.0/include \ | ||
99 | ${datadir}/gtk-4.0/valgrind \ | ||
100 | ${datadir}/gettext/its \ | ||
101 | ${bindir}/gtk4-builder-tool \ | ||
102 | ${bindir}/gtk4-encode-symbolic-svg \ | ||
103 | ${bindir}/gtk4-query-settings \ | ||
104 | " | ||
105 | |||
106 | GTKBASE_RRECOMMENDS ?= " \ | ||
107 | liberation-fonts \ | ||
108 | gdk-pixbuf-loader-png \ | ||
109 | gdk-pixbuf-loader-jpeg \ | ||
110 | gdk-pixbuf-loader-gif \ | ||
111 | gdk-pixbuf-loader-xpm \ | ||
112 | shared-mime-info \ | ||
113 | adwaita-icon-theme-symbolic \ | ||
114 | " | ||
115 | |||
116 | GTKBASE_RRECOMMENDS:class-native ?= "" | ||
117 | |||
118 | GTKGLIBC_RRECOMMENDS ?= "${GTKBASE_RRECOMMENDS} glibc-gconv-iso8859-1" | ||
119 | |||
120 | RRECOMMENDS:${PN} = "${GTKBASE_RRECOMMENDS}" | ||
121 | RRECOMMENDS:${PN}:libc-glibc = "${GTKGLIBC_RRECOMMENDS}" | ||
122 | RDEPENDS:${PN}-dev += "${@bb.utils.contains("PACKAGECONFIG", "wayland", "wayland-protocols", "", d)}" | ||
123 | |||
124 | PACKAGES_DYNAMIC += "^gtk4-printbackend-.*" | ||
125 | python populate_packages:prepend () { | ||
126 | import os.path | ||
127 | |||
128 | gtk_libdir = d.expand('${libdir}/gtk-4.0/${LIBV}') | ||
129 | printmodules_root = os.path.join(gtk_libdir, 'printbackends'); | ||
130 | |||
131 | do_split_packages(d, printmodules_root, r'^libprintbackend-(.*)\.so$', 'gtk4-printbackend-%s', 'GTK printbackend module for %s') | ||
132 | |||
133 | if (d.getVar('DEBIAN_NAMES')): | ||
134 | d.setVar(d.expand('PKG:${PN}'), '${MLPREFIX}libgtk-4.0') | ||
135 | } | ||