summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gtk+/gdk-pixbuf-csource-native_2.12.7.bb
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2010-11-25 14:42:43 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-20 21:36:56 +0000
commit552169e89aea5706100a67f1f1e68a85600e1105 (patch)
treeba6246d958abd1c3d2ece313000c384f13436d9b /meta/recipes-gnome/gtk+/gdk-pixbuf-csource-native_2.12.7.bb
parent8f23c1413ad12e60e98f9887cafa4315db7b62a2 (diff)
downloadpoky-552169e89aea5706100a67f1f1e68a85600e1105.tar.gz
gdk-pixbuf: Add 2.22.1 as new recipe
Updating gtk+ to 2.23.2 requires gdk-pixbuf, which is originaly a module in gtk+. Borrow hardcoded_libtool.patch from original gtk+, and add configure_fix.patch to fix build failure in cross-compile environment. As gdk-pixbuf is a stand-alone package now, gdk-pixbuf-csource-native can be safely removed. So extend gdk-pixbuf with native support, and make related packages depend on it. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-gnome/gtk+/gdk-pixbuf-csource-native_2.12.7.bb')
-rw-r--r--meta/recipes-gnome/gtk+/gdk-pixbuf-csource-native_2.12.7.bb37
1 files changed, 0 insertions, 37 deletions
diff --git a/meta/recipes-gnome/gtk+/gdk-pixbuf-csource-native_2.12.7.bb b/meta/recipes-gnome/gtk+/gdk-pixbuf-csource-native_2.12.7.bb
deleted file mode 100644
index 0c8506a8e7..0000000000
--- a/meta/recipes-gnome/gtk+/gdk-pixbuf-csource-native_2.12.7.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1require gtk+_${PV}.bb
2inherit native
3DEPENDS = "jpeg-native libpng-native gettext-native glib-2.0-native libx11-native"
4S = "${WORKDIR}/gtk+-${PV}"
5FILESPATH = "${FILE_DIRNAME}/gdk-pixbuf-csource:${FILE_DIRNAME}/gtk+-${PV}:${FILE_DIRNAME}/files"
6SRC_URI += "file://reduce-dependencies.patch;patch=1"
7PR = "r13"
8
9#clear recommends for uclibc builds
10RRECOMMENDS_${PN} = " "
11RRECOMMENDS_${PN}_linux = " "
12RRECOMMENDS_${PN}_linux-gnueabi = " "
13
14EXTRA_OECONF = "\
15 --with-gdktarget=x11 \
16 --without-libtiff \
17 --with-libjpeg \
18 --with-libpng \
19 --x-includes=${STAGING_INCDIR} \
20 --x-libraries=${STAGING_LIBDIR} \
21"
22
23PACKAGES_DYNAMIC = ""
24
25do_compile() {
26 cd gdk-pixbuf && oe_runmake
27}
28
29do_install() {
30 cd gdk-pixbuf
31 oe_runmake 'DESTDIR=${D}' install
32 install -d ${D}${sysconfdir}/gtk-2.0
33 GDK_PIXBUF_MODULEDIR=${D}${libdir}/gtk-2.0/2.10.0/loaders ${D}${bindir}/gdk-pixbuf-query-loaders > ${D}${sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
34 sed -i -e 's#${D}##g' ${D}${sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
35 find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \;
36}
37