summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-11-25 19:27:58 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-29 17:43:40 +0000
commit88375498737bd86b9dff6be4bd1f83486742d8a8 (patch)
tree96b4a9f7c893f9a5f563fa435b0e71bee1b46772 /meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb
parent315cc3ab703dc4f00b8b3d32a69942ec36aefc72 (diff)
downloadpoky-88375498737bd86b9dff6be4bd1f83486742d8a8.tar.gz
gdk-pixbuf: upgrade 2.38.2 -> 2.40.0
(From OE-Core rev: 081f1e043e6e5929dd54b25d440f8e7b8a15f142) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb')
-rw-r--r--meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb127
1 files changed, 127 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb
new file mode 100644
index 0000000000..699c4ecd0b
--- /dev/null
+++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb
@@ -0,0 +1,127 @@
1SUMMARY = "Image loading library for GTK+"
2DESCRIPTION = "The GDK Pixbuf library provides: Image loading and saving \
3facilities, fast scaling and compositing of pixbufs and Simple animation \
4loading (ie. animated GIFs)"
5HOMEPAGE = "https://wiki.gnome.org/Projects/GdkPixbuf"
6BUGTRACKER = "https://gitlab.gnome.org/GNOME/gdk-pixbuf/issues"
7
8LICENSE = "LGPLv2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
10 file://gdk-pixbuf/gdk-pixbuf.h;endline=26;md5=72b39da7cbdde2e665329fef618e1d6b \
11 "
12
13SECTION = "libs"
14
15DEPENDS = "glib-2.0 gdk-pixbuf-native shared-mime-info"
16
17MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
18
19SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \
20 file://run-ptest \
21 file://fatal-loader.patch \
22 file://0001-Work-around-thumbnailer-cross-compile-failure.patch \
23 file://0001-Fix-a-couple-of-decisions-around-cross-compilation.patch \
24 file://0004-Do-not-run-tests-when-building.patch \
25 file://0006-Build-thumbnailer-and-tests-also-in-cross-builds.patch \
26 file://missing-test-data.patch \
27 "
28
29SRC_URI_append_class-target = " \
30 file://0003-target-only-Work-around-thumbnailer-cross-compile-fa.patch \
31 "
32SRC_URI_append_class-nativesdk = " \
33 file://0003-target-only-Work-around-thumbnailer-cross-compile-fa.patch \
34 "
35
36SRC_URI[md5sum] = "05eb1ebc258ba905f1c8644ef49de064"
37SRC_URI[sha256sum] = "1582595099537ca8ff3b99c6804350b4c058bb8ad67411bbaae024ee7cead4e6"
38
39inherit meson pkgconfig gettext pixbufcache ptest-gnome upstream-version-is-even gobject-introspection gtk-doc lib_package
40
41GIR_MESON_OPTION = 'gir'
42
43EXTRA_OEMESON_append = " ${@bb.utils.contains('PTEST_ENABLED', '1', '-Dinstalled_tests=true', '-Dinstalled_tests=false', d)}"
44
45LIBV = "2.10.0"
46
47GDK_PIXBUF_LOADERS ?= "png jpeg"
48
49PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} ${GDK_PIXBUF_LOADERS}"
50PACKAGECONFIG_class-native = "${GDK_PIXBUF_LOADERS}"
51
52PACKAGECONFIG[png] = "-Dpng=true,-Dpng=false,libpng"
53PACKAGECONFIG[jpeg] = "-Djpeg=true,-Djpeg=false,jpeg"
54PACKAGECONFIG[tiff] = "-Dtiff=true,-Dtiff=false,tiff"
55PACKAGECONFIG[jpeg2000] = "-Djasper=true,-Djasper=false,jasper"
56
57PACKAGECONFIG[x11] = "-Dx11=true,-Dx11=false,virtual/libx11"
58
59PACKAGES =+ "${PN}-xlib"
60
61# For GIO image type sniffing
62RDEPENDS_${PN} = "shared-mime-info"
63
64FILES_${PN}-xlib = "${libdir}/*pixbuf_xlib*${SOLIBS}"
65ALLOW_EMPTY_${PN}-xlib = "1"
66
67FILES_${PN} += "${libdir}/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders"
68
69FILES_${PN}-bin += "${datadir}/thumbnailers/gdk-pixbuf-thumbnailer.thumbnailer"
70
71FILES_${PN}-dev += " \
72 ${bindir}/gdk-pixbuf-csource \
73 ${bindir}/gdk-pixbuf-pixdata \
74 ${bindir}/gdk-pixbuf-print-mime-types \
75 ${includedir}/* \
76 ${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders/*.la \
77"
78
79PACKAGES_DYNAMIC += "^gdk-pixbuf-loader-.*"
80PACKAGES_DYNAMIC_class-native = ""
81
82python populate_packages_prepend () {
83 postinst_pixbufloader = d.getVar("postinst_pixbufloader")
84
85 loaders_root = d.expand('${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders')
86
87 packages = ' '.join(do_split_packages(d, loaders_root, r'^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s'))
88 d.setVar('PIXBUF_PACKAGES', packages)
89
90 # The test suite exercises all the loaders, so ensure they are all
91 # dependencies of the ptest package.
92 d.appendVar("RDEPENDS_%s-ptest" % d.getVar('PN'), " " + packages)
93}
94
95do_install_append() {
96 # Copy gdk-pixbuf-query-loaders into libdir so it is always available
97 # in multilib builds.
98 cp ${D}/${bindir}/gdk-pixbuf-query-loaders ${D}/${libdir}/gdk-pixbuf-2.0/
99
100}
101
102do_install_append_class-native() {
103 find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \;
104
105 create_wrapper ${D}/${bindir}/gdk-pixbuf-csource \
106 XDG_DATA_DIRS=${STAGING_DATADIR} \
107 GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
108
109 create_wrapper ${D}/${bindir}/gdk-pixbuf-pixdata \
110 XDG_DATA_DIRS=${STAGING_DATADIR} \
111 GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
112
113 create_wrapper ${D}/${bindir}/gdk-pixbuf-print-mime-types \
114 XDG_DATA_DIRS=${STAGING_DATADIR} \
115 GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
116
117 create_wrapper ${D}/${libdir}/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders \
118 XDG_DATA_DIRS=${STAGING_DATADIR} \
119 GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache \
120 GDK_PIXBUF_MODULEDIR=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders
121
122 create_wrapper ${D}/${bindir}/gdk-pixbuf-query-loaders \
123 XDG_DATA_DIRS=${STAGING_DATADIR} \
124 GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache \
125 GDK_PIXBUF_MODULEDIR=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders
126}
127BBCLASSEXTEND = "native nativesdk"