summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 14:36:22 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 15:32:53 +0200
commitf4cf9fe05bb3f32fabea4e54dd92d368967a80da (patch)
tree487180fa9866985ea7b28e625651765d86f515c3 /meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb
downloadpoky-f4cf9fe05bb3f32fabea4e54dd92d368967a80da.tar.gz
initial commit for Enea Linux 4.0
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb')
-rw-r--r--meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb105
1 files changed, 105 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb
new file mode 100644
index 0000000000..50e54d8eab
--- /dev/null
+++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.30.3.bb
@@ -0,0 +1,105 @@
1SUMMARY = "Image loading library for GTK+"
2HOMEPAGE = "http://www.gtk.org/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
7 file://gdk-pixbuf/gdk-pixbuf.h;endline=26;md5=5066b71daefeff678494fffa3040aba9"
8
9SECTION = "libs"
10
11DEPENDS = "glib-2.0"
12DEPENDS_append_linuxstdbase = " virtual/libx11"
13
14MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
15
16SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \
17 file://hardcoded_libtool.patch \
18 file://extending-libinstall-dependencies.patch \
19 file://run-ptest \
20 file://tests-check.patch \
21 file://fatal-loader.patch \
22 "
23
24SRC_URI[md5sum] = "81161cc895eb43afd9ae7354b87e2261"
25SRC_URI[sha256sum] = "c229c53f59573eab9410b53690a4b9db770312c80a4d84ecd6295aa894574494"
26
27inherit autotools pkgconfig gettext pixbufcache ptest
28
29LIBV = "2.10.0"
30
31GDK_PIXBUF_LOADERS ?= "png jpeg"
32
33PACKAGECONFIG ??= "${GDK_PIXBUF_LOADERS}"
34PACKAGECONFIG_linuxstdbase = "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} ${GDK_PIXBUF_LOADERS}"
35PACKAGECONFIG_class-native = "${GDK_PIXBUF_LOADERS}"
36
37PACKAGECONFIG[png] = "--with-libpng,--without-libpng,libpng"
38PACKAGECONFIG[jpeg] = "--with-libjpeg,--without-libjpeg,jpeg"
39PACKAGECONFIG[tiff] = "--with-libtiff,--without-libtiff,tiff"
40PACKAGECONFIG[jpeg2000] = "--with-libjasper,--without-libjasper,jasper"
41
42# Use GIO to sniff image format instead of trying all loaders
43PACKAGECONFIG[gio-sniff] = "--enable-gio-sniffing,--disable-gio-sniffing,,shared-mime-info"
44PACKAGECONFIG[x11] = "--with-x11,--without-x11,virtual/libx11"
45
46EXTRA_OECONF = "\
47 --disable-introspection \
48 ${@base_contains('DISTRO_FEATURES', 'ptest', '--enable-installed-tests', '--disable-installed-tests', d)} \
49"
50
51PACKAGES =+ "${PN}-xlib"
52
53FILES_${PN}-xlib = "${libdir}/*pixbuf_xlib*${SOLIBS}"
54ALLOW_EMPTY_${PN}-xlib = "1"
55
56FILES_${PN} = "${bindir}/gdk-pixbuf-query-loaders \
57 ${bindir}/gdk-pixbuf-pixdata \
58 ${libdir}/lib*.so.*"
59
60FILES_${PN}-dev += " \
61 ${bindir}/gdk-pixbuf-csource \
62 ${includedir}/* \
63 ${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders/*.la \
64"
65
66FILES_${PN}-dbg += " \
67 ${libdir}/.debug/* \
68 ${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders/.debug/* \
69"
70
71FILES_${PN}-ptest += "${libdir}/gdk-pixbuf/installed-tests \
72 ${datadir}/installed-tests/gdk-pixbuf"
73
74RDEPENDS_${PN}-ptest += "gnome-desktop-testing"
75
76PACKAGES_DYNAMIC += "^gdk-pixbuf-loader-.*"
77PACKAGES_DYNAMIC_class-native = ""
78
79python populate_packages_prepend () {
80 postinst_pixbufloader = d.getVar("postinst_pixbufloader", True)
81
82 loaders_root = d.expand('${libdir}/gdk-pixbuf-2.0/${LIBV}/loaders')
83
84 packages = ' '.join(do_split_packages(d, loaders_root, '^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s'))
85 d.setVar('PIXBUF_PACKAGES', packages)
86
87 # The test suite exercises all the loaders, so ensure they are all
88 # dependencies of the ptest package.
89 d.appendVar("RDEPENDS_gdk-pixbuf-ptest", " " + packages)
90}
91
92do_install_append_class-native() {
93 find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \;
94
95 create_wrapper ${D}/${bindir}/gdk-pixbuf-csource \
96 GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
97
98 create_wrapper ${D}/${bindir}/gdk-pixbuf-pixdata \
99 GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache
100
101 create_wrapper ${D}/${bindir}/gdk-pixbuf-query-loaders \
102 GDK_PIXBUF_MODULE_FILE=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders.cache \
103 GDK_PIXBUF_MODULEDIR=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/${LIBV}/loaders
104}
105BBCLASSEXTEND = "native"