summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gcr/gcr3_3.41.1.bb
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2023-01-07 04:50:02 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-12 23:08:58 +0000
commitd2410b591f3feb5264747b25ef0793516161d087 (patch)
tree390d0c174010a7a28514e90beaafccbfe7439223 /meta/recipes-gnome/gcr/gcr3_3.41.1.bb
parent755ee95a45a4a5e3f880b6143e755ec699194416 (diff)
downloadpoky-d2410b591f3feb5264747b25ef0793516161d087.tar.gz
gcr3: update 3.40.0 -> 3.41.1
- remove unneded backport patches - partly import the patch to fix ssh_agent option from gcr4 recipe - convert from gtk-doc to gi-docgen gcr 3.41.1: - meson: Fix unknown kw argument in gnome.generate_gir [GNOME/gcr!68] - gcr: Add G_SPAWN_CLOEXEC_PIPES flag to all the g_spawn commands - docs: Port from gtk-doc to gi-docgen [GNOME/gcr!76] - Unbreak build without systemd [GNOME/gcr!75] - Several CI fixes - Updated translations gcr 3.41.0: - Port ssh-agent from gnome-keyring [GNOME/gcr!67] - build: Fix parallel build failure due to missing marshal dependency [GNOME/gcr!68] - Fix warnings by dropping `volatile` for g_once_init_inter locations [GNOME/gcr!69] - tests: More robust against GTask unref race condition [GNOME/gcr!72,GNOME/gcr#84] - Updated translations (From OE-Core rev: 9d66a3e9b9908592050ad706a950d76b6499a49e) Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/gcr/gcr3_3.41.1.bb')
-rw-r--r--meta/recipes-gnome/gcr/gcr3_3.41.1.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gcr/gcr3_3.41.1.bb b/meta/recipes-gnome/gcr/gcr3_3.41.1.bb
new file mode 100644
index 0000000000..ba5660a5ed
--- /dev/null
+++ b/meta/recipes-gnome/gcr/gcr3_3.41.1.bb
@@ -0,0 +1,59 @@
1SUMMARY = "A library for bits of crypto UI and parsing etc"
2DESCRIPTION = "GCR is a library for displaying certificates, and crypto UI, \
3accessing key stores. It also provides the viewer for crypto files on the \
4GNOME desktop."
5HOMEPAGE = "https://gitlab.gnome.org/GNOME/gcr"
6BUGTRACKER = "https://gitlab.gnome.org/GNOME/gcr/issues"
7
8LICENSE = "GPL-2.0-only"
9LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
10
11DEPENDS = "p11-kit glib-2.0 libgcrypt gnupg-native \
12 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'libxslt-native', '', d)}"
13
14CACHED_CONFIGUREVARS += "ac_cv_path_GPG='gpg2'"
15
16CFLAGS += "-D_GNU_SOURCE"
17
18GNOMEBASEBUILDCLASS = "meson"
19GTKDOC_MESON_OPTION = "gtk_doc"
20inherit gnomebase gtk-icon-cache gi-docgen features_check upstream-version-is-even vala gobject-introspection gettext mime mime-xdg
21UPSTREAM_CHECK_REGEX = "[^\d\.](?P<pver>3.(?!9\d+)\d+(\.\d+)+)\.tar"
22
23SRC_URI = "https://download.gnome.org/sources/gcr/3.41/gcr-${PV}.tar.xz;name=archive"
24SRC_URI += "file://0001-meson.build-correctly-handle-disabled-ssh_agent-opti.patch"
25SRC_URI[archive.sha256sum] = "bb7128a3c2febbfee9c03b90d77d498d0ceb237b0789802d60185c71c4bea24f"
26
27S = "${WORKDIR}/gcr-${PV}"
28
29PACKAGECONFIG ??= " \
30 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
31 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk', '', d)} \
32 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'gtk', '', d)} \
33"
34PACKAGECONFIG[gtk] = "-Dgtk=true,-Dgtk=false,gtk+3"
35PACKAGECONFIG[ssh_agent] = "-Dssh_agent=true,-Dssh_agent=false,libsecret,openssh"
36#'Use systemd socket activation for server programs'
37PACKAGECONFIG[systemd] = "-Dsystemd=enabled,-Dsystemd=disabled,systemd"
38
39FILES:${PN} += " \
40 ${datadir}/dbus-1 \
41 ${datadir}/gcr-3 \
42 ${systemd_user_unitdir}/gcr-ssh-agent.socket \
43 ${systemd_user_unitdir}/gcr-ssh-agent.service \
44"
45
46# http://errors.yoctoproject.org/Errors/Details/20229/
47ARM_INSTRUCTION_SET:armv4 = "arm"
48ARM_INSTRUCTION_SET:armv5 = "arm"
49ARM_INSTRUCTION_SET:armv6 = "arm"
50
51EXTRA_OEMESON += "--cross-file ${WORKDIR}/meson-${PN}.cross"
52do_write_config:append() {
53 cat >${WORKDIR}/meson-${PN}.cross <<EOF
54[binaries]
55gpg2 = '${bindir}/gpg2'
56ssh-add = '${bindir}/ssh-add'
57ssh-agent = '${bindir}/ssh-agent'
58EOF
59}