summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/epiphany/epiphany_44.5.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2023-07-27 16:36:23 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-07-30 09:16:53 +0100
commit11cc1a1a882a7eb012c312b953cb5939feba985f (patch)
tree3c3aed9bf8567e5ecd5fece60d247163f3cf98c6 /meta/recipes-gnome/epiphany/epiphany_44.5.bb
parent254cc105eecb75ff36421e93414f8c148d244c7a (diff)
downloadpoky-11cc1a1a882a7eb012c312b953cb5939feba985f.tar.gz
epiphany: upgrade 43.1 -> 44.5
With this version, epiphany has transitioned to gtk4, and requires webkit built with gtk4 support (there is no choice, it's a hard break). Adjust the webkit recipe accordingly. There's also a new requirement for gcr 4.x and libadwaita. (From OE-Core rev: 6a300f48e783ee95ccad52fd47ad4e7d88279e4e) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/epiphany/epiphany_44.5.bb')
-rw-r--r--meta/recipes-gnome/epiphany/epiphany_44.5.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-gnome/epiphany/epiphany_44.5.bb b/meta/recipes-gnome/epiphany/epiphany_44.5.bb
new file mode 100644
index 0000000000..f92d149c88
--- /dev/null
+++ b/meta/recipes-gnome/epiphany/epiphany_44.5.bb
@@ -0,0 +1,44 @@
1SUMMARY = "WebKit based web browser for GNOME"
2DESCRIPTION = "Epiphany is an open source web browser for the Linux desktop environment. \
3It provides a simple and easy-to-use internet browsing experience."
4HOMEPAGE = "https://wiki.gnome.org/Apps/Web"
5BUGTRACKER = "https://gitlab.gnome.org/GNOME/epiphany"
6LICENSE = "GPL-3.0-or-later"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
9DEPENDS = " \
10 webkitgtk \
11 gcr \
12 gsettings-desktop-schemas \
13 nettle \
14 json-glib \
15 libadwaita \
16 libarchive \
17 libdazzle \
18 libhandy \
19 libportal \
20 libsoup \
21 glib-2.0-native \
22 coreutils-native \
23 desktop-file-utils-native \
24 "
25
26GNOMEBASEBUILDCLASS = "meson"
27inherit gnomebase gsettings features_check gettext mime-xdg gtk-icon-cache
28REQUIRED_DISTRO_FEATURES = "x11 opengl"
29
30SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@oe.utils.trim_version("${PV}", 1)}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive \
31 file://0002-help-meson.build-disable-the-use-of-yelp.patch \
32 file://migrator.patch \
33 file://distributor.patch \
34 "
35SRC_URI[archive.sha256sum] = "3c475e04ed2a0f410cb44b96937563697079193ac9b7a50c91485fb9b08315ab"
36
37# Developer mode enables debugging
38PACKAGECONFIG[developer-mode] = "-Ddeveloper_mode=true,-Ddeveloper_mode=false"
39
40FILES:${PN} += "${datadir}/dbus-1 ${datadir}/gnome-shell/search-providers ${datadir}/metainfo"
41RDEPENDS:${PN} = "iso-codes adwaita-icon-theme gsettings-desktop-schemas"
42
43# ANGLE requires SSE support as of webkit 2.40.x on 32 bit x86
44COMPATIBLE_HOST:x86 = "${@bb.utils.contains_any('TUNE_FEATURES', 'core2 corei7', '.*', 'null', d)}"