summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/epiphany/epiphany_3.16.3.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-06-10 15:41:01 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-14 20:46:36 +0100
commit23bf09be21623b9733caddc2934347539a42279d (patch)
tree3e3e6d1c8ba47f000cb83c2e17a2c938e2aa6ba3 /meta/recipes-gnome/epiphany/epiphany_3.16.3.bb
parent62fca975cf8621c2f0218dd8a37a8322c2cb09b8 (diff)
downloadpoky-23bf09be21623b9733caddc2934347539a42279d.tar.gz
epiphany: add a recipe from meta-gnome
Epiphany is replacing midori as the browser in oe-core recipe set and poky distribution. (From OE-Core rev: cf1ad936487d5d068304b6e2565bfd556d81baef) (From OE-Core rev: c000abbefcd2ce1180f1cf4468512c7c40a3cc8c) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome/epiphany/epiphany_3.16.3.bb')
-rw-r--r--meta/recipes-gnome/epiphany/epiphany_3.16.3.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-gnome/epiphany/epiphany_3.16.3.bb b/meta/recipes-gnome/epiphany/epiphany_3.16.3.bb
new file mode 100644
index 0000000000..506fb25dd6
--- /dev/null
+++ b/meta/recipes-gnome/epiphany/epiphany_3.16.3.bb
@@ -0,0 +1,24 @@
1SUMMARY = "WebKit based web browser for GNOME"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4
5DEPENDS = "libsoup-2.4 webkitgtk gtk+3 iso-codes ca-certificates avahi libnotify gcr libwnck3 \
6 gsettings-desktop-schemas gnome-desktop3"
7
8inherit gnomebase gsettings
9SRC_URI += "file://0001-yelp.m4-drop-the-check-for-itstool.patch"
10SRC_URI[archive.md5sum] = "3296af4532b8019775f4b40d21a341ae"
11SRC_URI[archive.sha256sum] = "d527f1770779ec22d955aeb13b148a846a26144e433ff0480c981af80e2390b1"
12
13EXTRA_OECONF += " --disable-nss --with-distributor-name=${DISTRO}"
14
15do_configure_prepend() {
16 touch ${S}/gnome-doc-utils.make
17 sed -i -e s:help::g ${S}/Makefile.am
18}
19
20FILES_${PN} += "${datadir}/appdata ${datadir}/dbus-1 ${datadir}/gnome-shell/search-providers"
21FILES_${PN}-dbg += "${libdir}/epiphany/*/web-extensions/.debug/libephywebextension.so"
22RDEPENDS_${PN} = "iso-codes adwaita-icon-theme"
23RRECOMMENDS_${PN} = "ca-certificates"
24