summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/zstd/zstd_1.4.9.bb
diff options
context:
space:
mode:
authorRandy MacLeod <randy.macleod@windriver.com>2021-03-14 11:50:34 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-15 14:37:40 +0000
commit27a7f3a35c1b0fed7a7f40b2b8431300c3f2ab78 (patch)
treef527fbb79eb41f4516ae72dda8c16d86bd22348e /meta/recipes-extended/zstd/zstd_1.4.9.bb
parenta6932c2203cf89f072b7e9a266fd22b384ece6a4 (diff)
downloadpoky-27a7f3a35c1b0fed7a7f40b2b8431300c3f2ab78.tar.gz
zstd: upgrade 1.4.8 -> 1.4.9
Shave fuzz off the Makefile-sort-all-wildcard-file-list-expansions patch CHANGELOG: v1.4.9 (Mar 1, 2021) bug: Use `umask()` to Constrain Created File Permissions (#2495, @felixhandte) bug: Make Simple Single-Pass Functions Ignore Advanced Parameters (#2498, @terrelln) api: Add (De)Compression Tracing Functionality (#2482, @terrelln) api: Support References to Multiple DDicts (#2446, @senhuang42) api: Add Function to Generate Skippable Frame (#2439, @senhuang42) perf: New Algorithms for the Long Distance Matcher (#2483, @mpu) perf: Performance Improvements for Long Distance Matcher (#2464, @mpu) perf: Don't Shrink Window Log when Streaming with a Dictionary (#2451, @terrelln) cli: Fix `--output-dir-mirror`'s Rejection of `..`-Containing Paths (#2512, @felixhandte) cli: Allow Input From Console When `-f`/`--force` is Passed (#2466, @felixhandte) cli: Improve Help Message (#2500, @senhuang42) tests: Remove Flaky Tests (#2455, #2486, #2445, @Cyan4973) tests: Correctly Invoke md5 Utility on NetBSD (#2492, @niacat) tests: Avoid Using `stat -c` on NetBSD (#2513, @felixhandte) build: Zstd CLI Can Now be Linked to Dynamic `libzstd` (#2457, #2454 @Cyan4973) build: Hide and Avoid Using Static-Only Symbols (#2501, #2504, @skitt) build: CMake: Enable Only C for lib/ and programs/ Projects (#2498, @concatime) build: CMake: Use `configure_file()` to Create the `.pc` File (#2462, @lazka) build: Fix Fuzzer Compiler Detection & Update UBSAN Flags (#2503, @terrelln) build: Add Guards for `_LARGEFILE_SOURCE` and `_LARGEFILE64_SOURCE` (#2444, @indygreg) build: Improve `zlibwrapper` Makefile (#2437, @Cyan4973) contrib: Add `recover_directory` Program (#2473, @terrelln) doc: Change License Year to 2021 (#2452 & #2465, @terrelln & @senhuang42) doc: Fix Typos (#2459, @ThomasWaldmann) (From OE-Core rev: 305c954a1d8aaeda3240523e4705c1b06e2c8590) Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/zstd/zstd_1.4.9.bb')
-rw-r--r--meta/recipes-extended/zstd/zstd_1.4.9.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/zstd/zstd_1.4.9.bb b/meta/recipes-extended/zstd/zstd_1.4.9.bb
new file mode 100644
index 0000000000..b86fdf8b2d
--- /dev/null
+++ b/meta/recipes-extended/zstd/zstd_1.4.9.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Zstandard - Fast real-time compression algorithm"
2DESCRIPTION = "Zstandard is a fast lossless compression algorithm, targeting \
3real-time compression scenarios at zlib-level and better compression ratios. \
4It's backed by a very fast entropy stage, provided by Huff0 and FSE library."
5HOMEPAGE = "http://www.zstd.net/"
6SECTION = "console/utils"
7
8LICENSE = "BSD-3-Clause & GPLv2"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=c7f0b161edbe52f5f345a3d1311d0b32 \
10 file://COPYING;md5=39bba7d2cf0ba1036f2a6e2be52fe3f0"
11
12SRC_URI = "git://github.com/facebook/zstd.git;branch=release \
13 file://0001-Makefile-sort-all-wildcard-file-list-expansions.patch \
14 "
15
16SRCREV = "e4558ffd1dc49399faf4ee5d85abed4386b4dcf5"
17UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
18
19S = "${WORKDIR}/git"
20
21PACKAGECONFIG ??= ""
22PACKAGECONFIG[lz4] = "HAVE_LZ4=1,HAVE_LZ4=0,lz4"
23PACKAGECONFIG[lzma] = "HAVE_LZMA=1,HAVE_LZMA=0,xz"
24PACKAGECONFIG[zlib] = "HAVE_ZLIB=1,HAVE_ZLIB=0,zlib"
25
26# See programs/README.md for how to use this
27ZSTD_LEGACY_SUPPORT ??= "4"
28
29do_compile () {
30 oe_runmake ${PACKAGECONFIG_CONFARGS} ZSTD_LEGACY_SUPPORT=${ZSTD_LEGACY_SUPPORT}
31}
32
33do_install () {
34 oe_runmake install 'DESTDIR=${D}'
35}
36
37BBCLASSEXTEND = "native nativesdk"