summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/xz/xz_5.2.0.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-12-26 17:35:32 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-27 22:53:39 +0000
commit088d4bb85cf7722723d2520585b74d3f7eddaafe (patch)
treece265f5da67ba55ce127ca9e3fe8b378d180510a /meta/recipes-extended/xz/xz_5.2.0.bb
parent8bc9af428246f6b670f3210ea5dc3a4b5c4d8679 (diff)
downloadpoky-088d4bb85cf7722723d2520585b74d3f7eddaafe.tar.gz
xz: upgrade to latest stable release 5.2.0
(From OE-Core rev: 13599899f84ece79779e787c52c3756484cd5df1) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/xz/xz_5.2.0.bb')
-rw-r--r--meta/recipes-extended/xz/xz_5.2.0.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-extended/xz/xz_5.2.0.bb b/meta/recipes-extended/xz/xz_5.2.0.bb
new file mode 100644
index 0000000000..3439ec911f
--- /dev/null
+++ b/meta/recipes-extended/xz/xz_5.2.0.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Utilities for managing LZMA compressed files"
2HOMEPAGE = "http://tukaani.org/xz/"
3SECTION = "base"
4
5# The source includes bits of PD, GPLv2, GPLv3, LGPLv2.1+, but the only file
6# which is GPLv3 is an m4 macro which isn't shipped in any of our packages,
7# and the LGPL bits are under lib/, which appears to be used for libgnu, which
8# appears to be used for DOS builds. So we're left with GPLv2+ and PD.
9LICENSE = "GPLv2+ & GPLv3+ & LGPLv2.1+ & PD"
10LICENSE_${PN} = "GPLv2+"
11LICENSE_${PN}-dev = "GPLv2+"
12LICENSE_${PN}-staticdev = "GPLv2+"
13LICENSE_${PN}-doc = "GPLv2+"
14LICENSE_${PN}-dbg = "GPLv2+"
15LICENSE_${PN}-locale = "GPLv2+"
16LICENSE_liblzma = "PD"
17LICENSE_liblzma-dev = "PD"
18LICENSE_liblzma-staticdev = "PD"
19LICENSE_liblzma-dbg = "PD"
20
21LIC_FILES_CHKSUM = "file://COPYING;md5=c475b6c7dca236740ace4bba553e8e1c \
22 file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
23 file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \
24 file://COPYING.LGPLv2.1;md5=4fbd65380cdd255951079008b364516c \
25 file://lib/getopt.c;endline=23;md5=2069b0ee710572c03bb3114e4532cd84 "
26
27SRC_URI = "http://tukaani.org/xz/xz-${PV}.tar.gz"
28SRC_URI[md5sum] = "be585bdf8672e4406632eda3d819e284"
29SRC_URI[sha256sum] = "231ef369982240bb20ed7cffa52bb12a4a297ce6871f480ab85e8a7ba98bf3d6"
30
31inherit autotools gettext
32
33PACKAGES =+ "liblzma liblzma-dev liblzma-staticdev liblzma-dbg"
34
35FILES_liblzma = "${libdir}/liblzma*${SOLIBS}"
36FILES_liblzma-dev = "${includedir}/lzma* ${libdir}/liblzma*${SOLIBSDEV} ${libdir}/liblzma.la ${libdir}/pkgconfig/liblzma.pc"
37FILES_liblzma-staticdev = "${libdir}/liblzma.a"
38FILES_liblzma-dbg = "${libdir}/.debug/liblzma*"
39
40BBCLASSEXTEND = "native nativesdk"
41
42export CONFIG_SHELL="/bin/sh"