summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/watchdog/watchdog-config.bb
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-26 16:55:02 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-09 11:53:36 +0100
commit38602249e2fb20eb4e9f95ea93e570eaf3a60cbe (patch)
tree38a3328fdcbdfd0da29fbc94c0b1d29f8f7938d5 /meta/recipes-extended/watchdog/watchdog-config.bb
parent7a79aba22be0ca0bc3535dea64a79b697013337d (diff)
downloadpoky-38602249e2fb20eb4e9f95ea93e570eaf3a60cbe.tar.gz
watchdog-config: Add recipe
Provides configuration files for watchdog. Add watchdog-config as a runtime dependence of watchdog and remove watchdog.conf file from watchdog installation. (From OE-Core rev: 6864ad2e863205472f8ea2057c61e949dc450151) Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/watchdog/watchdog-config.bb')
-rw-r--r--meta/recipes-extended/watchdog/watchdog-config.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-extended/watchdog/watchdog-config.bb b/meta/recipes-extended/watchdog/watchdog-config.bb
new file mode 100644
index 0000000000..8bf40f0f0e
--- /dev/null
+++ b/meta/recipes-extended/watchdog/watchdog-config.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Software watchdog"
2DESCRIPTION = "Watchdog is a daemon that checks if your system is still \
3working. If programs in user space are not longer executed it will reboot \
4the system."
5HOMEPAGE = "http://watchdog.sourceforge.net/"
6BUGTRACKER = "http://sourceforge.net/tracker/?group_id=172030&atid=860194"
7
8LICENSE = "MIT-X"
9LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
10
11SRC_URI = " \
12 file://watchdog.default \
13 file://watchdog.conf \
14"
15
16do_install() {
17 install -Dm 0644 ${WORKDIR}/watchdog.default ${D}${sysconfdir}/default/watchdog
18 install -Dm 0644 ${WORKDIR}/watchdog.conf ${D}${sysconfdir}/watchdog.conf
19}
20