summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2016h.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2016-10-23 20:00:15 -0700
committerSona Sarmadi <sona.sarmadi@enea.com>2017-02-10 12:21:37 +0100
commit55a57c0a3cdee5745fd9fdf10177660d6a6fa868 (patch)
tree51d0dd9eefa083096b135117f2ebdbd2699a67c1 /meta/recipes-extended/tzcode/tzcode-native_2016h.bb
parent9cc3e1c2ce4a572dce6329f161e549029d84ad30 (diff)
downloadpoky-55a57c0a3cdee5745fd9fdf10177660d6a6fa868.tar.gz
tzcode-native: update to 2016h
Changes to code zic no longer mishandles relativizing file names when creating symbolic links like /etc/localtime, when these symbolic links are outside the usual directory hierarchy. This fixes a bug introduced in 2016g. (Problem reported by Andreas Stieger.) (From OE-Core rev: 9c5de646e01a83219be74e99dcf7c1e56ba38b53) (From OE-Core rev: 9288b6e699abbf5b314029b0db9230ca159b335a) Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com>
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2016h.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2016h.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2016h.bb b/meta/recipes-extended/tzcode/tzcode-native_2016h.bb
new file mode 100644
index 0000000000..3032eaf470
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2016h.bb
@@ -0,0 +1,25 @@
1# note that we allow for us to use data later than our code version
2#
3SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
4LICENSE = "PD & BSD & BSD-3-Clause"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=ef1a352b901ee7b75a75df8171d6aca7"
7
8SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \
9 http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata"
10
11SRC_URI[tzcode.md5sum] = "00c20689d996dea4cf5b45504724ce8f"
12SRC_URI[tzcode.sha256sum] = "30e62f0b86a78fb020d378b950930da023ca31b1a58f08d8fb2066627c4d6566"
13SRC_URI[tzdata.md5sum] = "878f0ec3fd9e4026ea11dd1b649a315a"
14SRC_URI[tzdata.sha256sum] = "da1b74fc2dec2ce8b64948dafb0bfc2f923c830d421a7ae4d016226135697a64"
15
16S = "${WORKDIR}"
17
18inherit native
19
20do_install () {
21 install -d ${D}${bindir}/
22 install -m 755 zic ${D}${bindir}/
23 install -m 755 zdump ${D}${bindir}/
24 install -m 755 tzselect ${D}${bindir}/
25}