summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2016e.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2016-06-14 14:50:21 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-29 19:36:01 +0100
commit51e4dabf7013f81d699f26da9fdb08e36a535a02 (patch)
treec35d9c94c6536aed140d507a5b305cbbeb335ed2 /meta/recipes-extended/tzcode/tzcode-native_2016e.bb
parentff7c814661780ab95de219e21cf3e82051450e06 (diff)
downloadpoky-51e4dabf7013f81d699f26da9fdb08e36a535a02.tar.gz
tzcode: update to 2016e
V2: typo in title (jet lagged) Changes to code zic now outputs a dummy transition at time 2**31 - 1 in zones whose POSIX-style TZ strings contain a '<'. This mostly works around Qt bug 53071 <https://bugreports.qt.io/browse/QTBUG-53071>. (Thanks to Zhanibek Adilbekov for reporting the Qt bug.) Changes affecting documentation and commentary tz-link.htm says why governments should give plenty of notice for time zone or DST changes, and refers to Matt Johnson's blog post. tz-link.htm mentions Tzdata for Elixir. (Thanks to Matt Johnson.) (From OE-Core rev: 5f3340e5c966f4233e0cd4ec468b20a1fd5a7346) (From OE-Core rev: cf79454942bec75dbd830d09d35a70d5cd155772) Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2016e.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2016e.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2016e.bb b/meta/recipes-extended/tzcode/tzcode-native_2016e.bb
new file mode 100644
index 0000000000..1e0f298410
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2016e.bb
@@ -0,0 +1,26 @@
1# note that we allow for us to use data later than our code version
2#
3SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
4LICENSE = "PD & BSD & BSD-3-Clause"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=76ae2becfcb9a685041c6f166b44c2c2"
7
8SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \
9 http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata"
10
11SRC_URI[tzcode.md5sum] = "6e6d3f0046a9383aafba8c2e0708a3a3"
12SRC_URI[tzcode.sha256sum] = "57d8c4fcd5e8a90657d0e298eac5effb1a642119c92308db68d13a4612fa459e"
13
14SRC_URI[tzdata.md5sum] = "43f9f929a8baf0dd2f17efaea02c2d2a"
15SRC_URI[tzdata.sha256sum] = "ba00f899f18dc4048d7fa21f5e1fdef434496084eedc06f6caa15e5ecdb6bd81"
16
17S = "${WORKDIR}"
18
19inherit native
20
21do_install () {
22 install -d ${D}${bindir}/
23 install -m 755 zic ${D}${bindir}/
24 install -m 755 zdump ${D}${bindir}/
25 install -m 755 tzselect ${D}${bindir}/
26}