summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2016c.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2016-03-23 18:21:50 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-11 22:03:08 +0100
commit6dba9abd43f7584178de52b623c603a5d4fcec5c (patch)
treea656cc98285e391d4a5b81c972b8604eb06d9d18 /meta/recipes-extended/tzcode/tzcode-native_2016c.bb
parentbe42a1d4fdc9d26a9ff1f6f34e8cebae18958041 (diff)
downloadpoky-6dba9abd43f7584178de52b623c603a5d4fcec5c.tar.gz
tzcode: update to 2016c
(From OE-Core rev: 28032d8c3122b75ceb3f4a664a2b478c9a9a6a2c) Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2016c.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2016c.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2016c.bb b/meta/recipes-extended/tzcode/tzcode-native_2016c.bb
new file mode 100644
index 0000000000..06b92ea6e8
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2016c.bb
@@ -0,0 +1,25 @@
1# note that we allow for us to use data later than our code version
2#
3SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
4LICENSE = "PD & BSD & BSD-3-Clause"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=76ae2becfcb9a685041c6f166b44c2c2"
7
8SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \
9 http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata"
10
11SRC_URI[tzcode.md5sum] = "ffb82ab0b588138759902b4627a6a80d"
12SRC_URI[tzcode.sha256sum] = "344b1bd486935bca2b7baa47db3b99b32211c45f31ec0d1ead8bacd103c5a416"
13SRC_URI[tzdata.md5sum] = "0330ccd16140d3b6438a18dae9b34b93"
14SRC_URI[tzdata.sha256sum] = "8700d981e6f2007ac037dabb5d2b12f390e8629bbc30e564bc21cf0c069a2d48"
15
16S = "${WORKDIR}"
17
18inherit native
19
20do_install () {
21 install -d ${D}${bindir}/
22 install -m 755 zic ${D}${bindir}/
23 install -m 755 zdump ${D}${bindir}/
24 install -m 755 tzselect ${D}${bindir}/
25}