summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/slang/slang_2.2.4.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-04-15 15:16:21 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-18 05:51:25 +0100
commitc51061112deef9b910e60632f37ce404f1c10bd5 (patch)
tree09a509b1efa9b7ba54b1811f7034b683f4d2e6ab /meta/recipes-extended/slang/slang_2.2.4.bb
parent72ff13687700823adccfed1da670e951ff089677 (diff)
downloadpoky-c51061112deef9b910e60632f37ce404f1c10bd5.tar.gz
slang: Update to 2.2.4
- Removed fix-uclibc.patch as it's no longer required by the upstream - Removed requirment for png as we only need limited support for slang - fix license - disable Parallel Make (From OE-Core rev: 2f5ab5632e9c7be5fef5fcb57c52dbec7d0880f9) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/slang/slang_2.2.4.bb')
-rw-r--r--meta/recipes-extended/slang/slang_2.2.4.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-extended/slang/slang_2.2.4.bb b/meta/recipes-extended/slang/slang_2.2.4.bb
new file mode 100644
index 0000000000..2b000a4088
--- /dev/null
+++ b/meta/recipes-extended/slang/slang_2.2.4.bb
@@ -0,0 +1,34 @@
1SUMMARY = "The shared library for the S-Lang extension language"
2
3DESCRIPTION = "S-Lang is an interpreted language and a programming library. The \
4S-Lang language was designed so that it can be easily embedded into \
5a program to provide the program with a powerful extension language. \
6The S-Lang library, provided in this package, provides the S-Lang \
7extension language. S-Lang's syntax resembles C, which makes it easy \
8to recode S-Lang procedures in C if you need to."
9
10SECTION = "libs"
11PRIORITY = "optional"
12DEPENDS = "pcre"
13PR = "r5"
14
15LICENSE = "GPLv2"
16LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02"
17
18
19SRC_URI = "ftp://space.mit.edu/pub/davis/slang/v2.2/slang-${PV}.tar.bz2 \
20 "
21
22inherit autotools
23
24SRC_URI[md5sum] = "7fcfd447e378f07dd0c0bae671fe6487"
25SRC_URI[sha256sum] = "9a8257a9a2a55099af858b13338dc8f3a06dd2069f46f0df2c9c3bb84a01d5db"
26
27EXTRA_OECONF += " --without-png"
28do_install() {
29 oe_runmake install DESTDIR=${D} -e 'INST_LIB_DIR=${STAGING_DIR_HOST}/usr/lib'
30}
31
32FILES_${PN} += "${datadir}/slsh/"
33
34PARALLEL_MAKE = ""