summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/slang/slang_2.2.4.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-07-25 01:16:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-26 08:56:26 +0100
commit91a6f3a3756219ae91435d60a0ceb8fd36fd056f (patch)
tree21bdd5c6f6e46fbbbbbcca4e26fe1e01e0e7c037 /meta/recipes-extended/slang/slang_2.2.4.bb
parent2186bbca70cfcec42b01484126d654bfec987ae0 (diff)
downloadpoky-91a6f3a3756219ae91435d60a0ceb8fd36fd056f.tar.gz
slang: 2.2.4 -> 2.3.0
* Removed: change-char-type-to-signed-char-in-macros.patch sprintf-bug-concerning-8-bit-characters.patch They are already in the source. * Updated: fix-check-pcre.patch fix-check-pcre.patch slang-fix-the-iconv-existence-checking.patch * Use SECURITY_NO_PIE_CFLAGS for SECURITY_CFLAGS, it can't be built with "-pie -fpie": tmp/sysroots/qemux86-64/usr/lib64/../lib64/Scrt1.o: In function `_start': /usr/src/debug/glibc/2.24-r0/git/csu/../sysdeps/x86_64/start.S:104: undefined reference to `main' /tmp/ccMFTA8A.o: In function `smg_char_at': /usr/src/debug/slang/2.3.0-r0/slang-2.3.0/modules/slsmg-module.c:134: undefined reference to `SLsmg_char_at' /tmp/ccMFTA8A.o: In function `smg_resume_smg': (From OE-Core rev: b2d6e069b9ecc5a13754393200a6fa48cdaaf4c6) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/slang/slang_2.2.4.bb')
-rw-r--r--meta/recipes-extended/slang/slang_2.2.4.bb54
1 files changed, 0 insertions, 54 deletions
diff --git a/meta/recipes-extended/slang/slang_2.2.4.bb b/meta/recipes-extended/slang/slang_2.2.4.bb
deleted file mode 100644
index 237e9f2526..0000000000
--- a/meta/recipes-extended/slang/slang_2.2.4.bb
+++ /dev/null
@@ -1,54 +0,0 @@
1SUMMARY = "The shared library for the S-Lang extension language"
2
3DESCRIPTION = "S-Lang is an interpreted language and a programming library. The \
4S-Lang language was designed so that it can be easily embedded into \
5a program to provide the program with a powerful extension language. \
6The S-Lang library, provided in this package, provides the S-Lang \
7extension language. S-Lang's syntax resembles C, which makes it easy \
8to recode S-Lang procedures in C if you need to."
9
10HOMEPAGE = "http://www.jedsoft.org/slang/"
11SECTION = "libs"
12DEPENDS = "pcre ncurses"
13PR = "r12"
14
15LICENSE = "GPLv2"
16LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02"
17
18
19SRC_URI = "http://www.jedsoft.org/releases/slang/old/slang-${PV}.tar.bz2 \
20 file://rpathfix.patch \
21 file://fix-check-pcre.patch \
22 file://change-char-type-to-signed-char-in-macros.patch \
23 file://sprintf-bug-concerning-8-bit-characters.patch \
24 file://slang-fix-the-iconv-existence-checking.patch \
25 file://0001-Fix-error-conflicting-types-for-posix_close.patch \
26 "
27UPSTREAM_CHECK_URI = "http://www.jedsoft.org/releases/slang/"
28
29inherit autotools-brokensep
30
31CLEANBROKEN = "1"
32
33SRC_URI[md5sum] = "7fcfd447e378f07dd0c0bae671fe6487"
34SRC_URI[sha256sum] = "9a8257a9a2a55099af858b13338dc8f3a06dd2069f46f0df2c9c3bb84a01d5db"
35
36EXTRA_OECONF += " --without-z --without-png --without-onig --x-includes=${STAGING_DIR_HOST}/usr/include/X11 --x-libraries=${STAGING_DIR_HOST}/usr/lib"
37
38do_configure_prepend() {
39 # slang keeps configure.ac and rest of autoconf files in autoconf/ directory
40 # we have to go there to be able to run gnu-configize cause it expects configure.{in,ac}
41 # to be present. Resulting files land in autoconf/autoconf/ so we need to move them.
42 cd ${S}/autoconf && gnu-configize --force && mv autoconf/config.* .
43 cd ${B}
44}
45
46do_install() {
47 oe_runmake install DESTDIR=${D} -e 'INST_LIB_DIR=${STAGING_DIR_HOST}/usr/lib'
48}
49
50FILES_${PN} += "${libdir}/${BPN}/v2/modules/ ${datadir}/slsh/"
51
52PARALLEL_MAKE = ""
53
54BBCLASSEXTEND = "native"