summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/slang/slang_2.2.4.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-08-31 06:37:01 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-12 22:48:37 +0100
commit27a850ab08043c99681098183173e8f71e3d737d (patch)
treed5e76e94353e9899602e01c43a57c623b7f06364 /meta/recipes-extended/slang/slang_2.2.4.bb
parent5ee0383697a1601b225e9df9bb4e532ba427aa1b (diff)
downloadpoky-27a850ab08043c99681098183173e8f71e3d737d.tar.gz
slang: Fix namespace conflict vis-a-vis posix_close
Fixes errors like | /home/ubuntu/work/oe/openembedded-core/build/tmp-musl/work/core2-64-oe-linux-musl/slang/2.2.4-r12/slang-2.2.4/src/slpo sio.c:366:12: error: conflicting types for 'posix_close' | static int posix_close (SLFile_FD_Type *f) | ^ | In file included from /home/ubuntu/work/oe/openembedded-core/build/tmp-musl/work/core2-64-oe-linux-musl/slang/2.2.4-r1 2/slang-2.2.4/src/slinclud.h:20:0, | from /home/ubuntu/work/oe/openembedded-core/build/tmp-musl/work/core2-64-oe-linux-musl/slang/2.2.4-r1 2/slang-2.2.4/src/slposio.c:24: | /home/ubuntu/work/oe/openembedded-core/build/tmp-musl/sysroots/qemux86-64/usr/include/unistd.h:38:5: note: previous de claration of 'posix_close' was here | int posix_close(int, int); | ^ | make[1]: *** [/home/ubuntu/work/oe/openembedded-core/build/tmp-musl/work/core2-64-oe-linux-musl/slang/2.2.4-r12/slang- 2.2.4/src/elfobjs/slposio.o] Error 1 (From OE-Core rev: 6b0cebe506b73cee7591089b624b69e009100c89) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/slang/slang_2.2.4.bb')
-rw-r--r--meta/recipes-extended/slang/slang_2.2.4.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-extended/slang/slang_2.2.4.bb b/meta/recipes-extended/slang/slang_2.2.4.bb
index 25f1b0c08d..5122f53da3 100644
--- a/meta/recipes-extended/slang/slang_2.2.4.bb
+++ b/meta/recipes-extended/slang/slang_2.2.4.bb
@@ -22,6 +22,7 @@ SRC_URI = "ftp://space.mit.edu/pub/davis/slang/v2.2/slang-${PV}.tar.bz2 \
22 file://change-char-type-to-signed-char-in-macros.patch \ 22 file://change-char-type-to-signed-char-in-macros.patch \
23 file://sprintf-bug-concerning-8-bit-characters.patch \ 23 file://sprintf-bug-concerning-8-bit-characters.patch \
24 file://slang-fix-the-iconv-existence-checking.patch \ 24 file://slang-fix-the-iconv-existence-checking.patch \
25 file://0001-Fix-error-conflicting-types-for-posix_close.patch \
25 " 26 "
26 27
27inherit autotools-brokensep 28inherit autotools-brokensep