summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-23 20:57:20 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-24 17:24:14 +0100
commit9bed1a3e5286d5cfd71ef7de89b00cd2b1e09286 (patch)
tree350d899b6621e1a6a05197d903c5b97ba6967f54 /meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb
parent1146eeb5b79e7437718495ee820bde059a75db3c (diff)
downloadpoky-9bed1a3e5286d5cfd71ef7de89b00cd2b1e09286.tar.gz
shadow: Move common code to shadow.inc
(From OE-Core rev: ec64632d312a099c7c544af63b25e2defde0038e) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb')
-rw-r--r--meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb53
1 files changed, 4 insertions, 49 deletions
diff --git a/meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb b/meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb
index 1ed5d4e011..ba208f7888 100644
--- a/meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb
+++ b/meta/recipes-extended/shadow/shadow-native_4.1.4.3.bb
@@ -1,60 +1,15 @@
1SUMMARY = "Tools to change and administer password and group data" 1require shadow.inc
2DESCRIPTION = "Tools to change and administer password and group data"
3HOMEPAGE = "http://pkg-shadow.alioth.debian.org"
4BUGTRACKER = "https://alioth.debian.org/tracker/?group_id=30580"
5SECTION = "base utils"
6LICENSE = "BSD | Artistic-1.0"
7LIC_FILES_CHKSUM = "file://COPYING;md5=08c553a87d4e51bbed50b20e0adcaede \
8 file://src/passwd.c;beginline=8;endline=30;md5=d83888ea14ae61951982d77125947661"
9 2
10PR = "r8" 3PR = "r8"
11 4
12SRC_URI = "http://pkg-shadow.alioth.debian.org/releases/${BPN}-${PV}.tar.bz2 \ 5SRC_URI += " \
13 file://shadow.automake-1.11.patch \
14 file://shadow-4.1.3-dots-in-usernames.patch \
15 file://shadow-4.1.4.2-env-reset-keep-locale.patch \
16 file://add_root_cmd_options.patch \ 6 file://add_root_cmd_options.patch \
17 file://disable-syslog.patch \ 7 file://disable-syslog.patch \
18 file://useradd.patch \ 8 file://useradd.patch \
19 file://shadow_fix_for_automake-1.12.patch \
20 file://add_root_cmd_groupmems.patch \ 9 file://add_root_cmd_groupmems.patch \
21 " 10 "
11inherit native
22 12
23SRC_URI[md5sum] = "b8608d8294ac88974f27b20f991c0e79" 13EXTRA_OECONF += "--without-libpam \
24SRC_URI[sha256sum] = "633f5bb4ea0c88c55f3642c97f9d25cbef74f82e0b4cf8d54e7ad6f9f9caa778"
25
26inherit autotools gettext native
27
28EXTRA_OECONF += "--without-audit \
29 --without-libcrack \
30 --without-libpam \
31 --without-selinux \
32 --without-nscd" 14 --without-nscd"
33 15
34do_install() {
35 oe_runmake DESTDIR="${D}" sbindir="${base_sbindir}" usbindir="${sbindir}" install
36
37 # Info dir listing isn't interesting at this point so remove it if it exists.
38 if [ -e "${D}${infodir}/dir" ]; then
39 rm -f ${D}${infodir}/dir
40 fi
41
42 # Enable CREATE_HOME by default.
43 sed -i 's/#CREATE_HOME/CREATE_HOME/g' ${D}${sysconfdir}/login.defs
44
45 # As we are on an embedded system, ensure the users mailbox is in
46 # ~/ not /var/spool/mail by default, as who knows where or how big
47 # /var is. The system MDA will set this later anyway.
48 sed -i 's/MAIL_DIR/#MAIL_DIR/g' ${D}${sysconfdir}/login.defs
49 sed -i 's/#MAIL_FILE/MAIL_FILE/g' ${D}${sysconfdir}/login.defs
50
51 # Disable checking emails.
52 sed -i 's/MAIL_CHECK_ENAB/#MAIL_CHECK_ENAB/g' ${D}${sysconfdir}/login.defs
53
54 # Now we don't have a mail system. Disable mail creation for now.
55 sed -i 's:/bin/bash:/bin/sh:g' ${D}${sysconfdir}/default/useradd
56 sed -i '/^CREATE_MAIL_SPOOL/ s:^:#:' ${D}${sysconfdir}/default/useradd
57
58 # Use users group by default
59 sed -i 's,^GROUP=1000,GROUP=100,g' ${D}${sysconfdir}/default/useradd
60}