summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/sed/sed_4.2.2.bb
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-06-09 15:45:52 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-13 12:31:38 +0100
commit6f0eb996ec0d1b77a5cc56a510036cd7db7c2836 (patch)
tree30cd648881bc2be00d1a949c120e4dca0b373629 /meta/recipes-extended/sed/sed_4.2.2.bb
parentbdf734343a5e033b071c98068a2f921b35534a61 (diff)
downloadpoky-6f0eb996ec0d1b77a5cc56a510036cd7db7c2836.tar.gz
sed: enable ptest support
Install sed test suite and run it as ptest. (From OE-Core rev: de8cc3192eefafa639a9f34fcc35799be3286191) Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/sed/sed_4.2.2.bb')
-rw-r--r--meta/recipes-extended/sed/sed_4.2.2.bb21
1 files changed, 18 insertions, 3 deletions
diff --git a/meta/recipes-extended/sed/sed_4.2.2.bb b/meta/recipes-extended/sed/sed_4.2.2.bb
index 47c8b5b14f..74ac16bea9 100644
--- a/meta/recipes-extended/sed/sed_4.2.2.bb
+++ b/meta/recipes-extended/sed/sed_4.2.2.bb
@@ -5,14 +5,19 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
5 file://sed/sed.h;beginline=1;endline=17;md5=767ab3a06d7584f6fd0469abaec4412f" 5 file://sed/sed.h;beginline=1;endline=17;md5=767ab3a06d7584f6fd0469abaec4412f"
6SECTION = "console/utils" 6SECTION = "console/utils"
7 7
8SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz" 8SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz \
9 file://sed-add-ptest.patch \
10 file://run-ptest \
11"
9 12
10SRC_URI[md5sum] = "4111de4faa3b9848a0686b2f260c5056" 13SRC_URI[md5sum] = "4111de4faa3b9848a0686b2f260c5056"
11SRC_URI[sha256sum] = "fea0a94d4b605894f3e2d5572e3f96e4413bcad3a085aae7367c2cf07908b2ff" 14SRC_URI[sha256sum] = "fea0a94d4b605894f3e2d5572e3f96e4413bcad3a085aae7367c2cf07908b2ff"
12 15
13inherit autotools texinfo update-alternatives gettext 16inherit autotools texinfo update-alternatives gettext ptest
17RDEPENDS_${PN}-ptest += "make locale-base-ru-ru"
14 18
15EXTRA_OECONF = "--disable-acl" 19EXTRA_OECONF = "--disable-acl \
20 ${@bb.utils.contains('PTEST_ENABLED', '1', '--enable-regex-tests', '', d)}"
16 21
17do_install () { 22do_install () {
18 autotools_do_install 23 autotools_do_install
@@ -25,4 +30,14 @@ ALTERNATIVE_${PN} = "sed"
25ALTERNATIVE_LINK_NAME[sed] = "${base_bindir}/sed" 30ALTERNATIVE_LINK_NAME[sed] = "${base_bindir}/sed"
26ALTERNATIVE_PRIORITY = "100" 31ALTERNATIVE_PRIORITY = "100"
27 32
33TESTDIR = "testsuite"
34
35do_compile_ptest() {
36 oe_runmake -C ${TESTDIR} buildtest-TESTS
37}
38
39do_install_ptest() {
40 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
41}
42
28BBCLASSEXTEND = "native" 43BBCLASSEXTEND = "native"