summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/rpcbind/rpcbind_0.2.2.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-04-29 00:29:56 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-30 23:04:15 +0100
commit43a60facf66f343ea5fc936bdd7fde65fa6e1714 (patch)
treeef5525a84422801f7c51a8a1bddc0867f357aa91 /meta/recipes-extended/rpcbind/rpcbind_0.2.2.bb
parent18ed8ec921c0c61f1782e45ab4d2f7d668bf9047 (diff)
downloadpoky-43a60facf66f343ea5fc936bdd7fde65fa6e1714.tar.gz
rpcbind: 0.2.2 -> 0.2.3
* Updated 0001-Avoid-use-of-glibc-sys-cdefs.h-header.patch * Removed 0002-uclibc-rpcsvc-defines.patch since it is already in the source. (From OE-Core rev: 713ac3bfbc95e58ce3332409bae838053fdeced8) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/rpcbind/rpcbind_0.2.2.bb')
-rw-r--r--meta/recipes-extended/rpcbind/rpcbind_0.2.2.bb75
1 files changed, 0 insertions, 75 deletions
diff --git a/meta/recipes-extended/rpcbind/rpcbind_0.2.2.bb b/meta/recipes-extended/rpcbind/rpcbind_0.2.2.bb
deleted file mode 100644
index 51e456e4bd..0000000000
--- a/meta/recipes-extended/rpcbind/rpcbind_0.2.2.bb
+++ /dev/null
@@ -1,75 +0,0 @@
1SUMMARY = "Universal Addresses to RPC Program Number Mapper"
2DESCRIPTION = "The rpcbind utility is a server that converts RPC \
3 program numbers into universal addresses."
4SECTION = "console/network"
5HOMEPAGE = "http://sourceforge.net/projects/rpcbind/"
6BUGTRACKER = "http://sourceforge.net/tracker/?group_id=201237&atid=976751"
7DEPENDS = "libtirpc quota"
8
9LICENSE = "BSD"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b46486e4c4a416602693a711bb5bfa39 \
11 file://src/rpcinfo.c;beginline=1;endline=27;md5=f8a8cd2cb25ac5aa16767364fb0e3c24"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/rpcbind/rpcbind-${PV}.tar.bz2 \
14 file://init.d \
15 file://0001-Avoid-use-of-glibc-sys-cdefs.h-header.patch \
16 file://0002-uclibc-rpcsvc-defines.patch \
17 file://remove-sys-queue.patch \
18 ${UCLIBCPATCHES} \
19 ${MUSLPATCHES} \
20 file://rpcbind.conf \
21 file://rpcbind.socket \
22 file://rpcbind.service \
23 "
24MUSLPATCHES_libc-musl = "file://musl-sunrpc.patch"
25
26UCLIBCPATCHES_libc-uclibc = "file://0001-uclibc-nss.patch \
27 file://0002-uclibc-rpcsvc-defines.patch \
28 "
29UCLIBCPATCHES ?= ""
30MUSLPATCHES ?= ""
31
32SRC_URI[md5sum] = "8acf839bfef2364a05fbd6be5f8edf9a"
33SRC_URI[sha256sum] = "13dbc8c796dbe0ce8df873007bea0490c8460b56202d918c9eb6fa0358a08f29"
34
35inherit autotools update-rc.d systemd pkgconfig
36
37PACKAGECONFIG ??= "tcp-wrappers"
38PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
39
40INITSCRIPT_NAME = "rpcbind"
41INITSCRIPT_PARAMS = "start 12 2 3 4 5 . stop 60 0 1 6 ."
42
43SYSTEMD_SERVICE_${PN} = "rpcbind.service"
44
45inherit useradd
46
47USERADD_PACKAGES = "${PN}"
48USERADD_PARAM_${PN} = "--system --no-create-home --home-dir / \
49 --shell /bin/false --user-group rpc"
50
51PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
52PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/, \
53 --without-systemdsystemunitdir, \
54 systemd \
55"
56
57EXTRA_OECONF += " --enable-warmstarts --with-rpcuser=rpc"
58
59do_install_append () {
60 mv ${D}${bindir} ${D}${sbindir}
61
62 install -d ${D}${sysconfdir}/init.d
63 sed -e 's,/etc/,${sysconfdir}/,g' \
64 -e 's,/sbin/,${sbindir}/,g' \
65 ${WORKDIR}/init.d > ${D}${sysconfdir}/init.d/rpcbind
66 chmod 0755 ${D}${sysconfdir}/init.d/rpcbind
67
68 install -m 0755 ${WORKDIR}/rpcbind.conf ${D}${sysconfdir}
69 install -d ${D}${systemd_unitdir}/system
70 install -m 0644 ${WORKDIR}/rpcbind.socket ${D}${systemd_unitdir}/system
71 install -m 0644 ${WORKDIR}/rpcbind.service ${D}${systemd_unitdir}/system
72 sed -i -e 's,@SBINDIR@,${sbindir},g' \
73 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
74 ${D}${systemd_unitdir}/system/rpcbind.service
75}