summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/polkit/polkit_0.103.bb
diff options
context:
space:
mode:
authorShane Wang <shane.wang@intel.com>2011-12-22 12:15:28 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-03 12:14:20 +0000
commitce7059238b3d7ec6f603ce15716ae00a889a3721 (patch)
treea146c9e5224c28d4dcf2e05c7f5a4f9ac346e520 /meta/recipes-extended/polkit/polkit_0.103.bb
parent6e3028cdec04851a8afc6bd17b2ba3a2adaea43d (diff)
downloadpoky-ce7059238b3d7ec6f603ce15716ae00a889a3721.tar.gz
polkit: upgrade to 0.103
This is the patch to upgrade polkit to 0.103. The license is changed because the HTML content is generated by GTK-Doc V1.18 (XML node) rather than GTK-Doc V1.17 (XML node), which causes the change of the tag. (From OE-Core rev: 114c0b6c423863b4ec27b5acbad3930ef1774306) Signed-off-by: Shane Wang <shane.wang@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/polkit/polkit_0.103.bb')
-rw-r--r--meta/recipes-extended/polkit/polkit_0.103.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-extended/polkit/polkit_0.103.bb b/meta/recipes-extended/polkit/polkit_0.103.bb
new file mode 100644
index 0000000000..7f5624228d
--- /dev/null
+++ b/meta/recipes-extended/polkit/polkit_0.103.bb
@@ -0,0 +1,33 @@
1SUMMARY = "PolicyKit Authorization Framework"
2DESCRIPTION = "The polkit package is an application-level toolkit for defining and handling the policy that allows unprivileged processes to speak to privileged processes."
3HOMEPAGE = "http://code.google.com/p/polkit/"
4LICENSE = "LGPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
6 file://src/polkit/polkit.h;beginline=1;endilne=20;md5=9f797b8912dac8a806be820c14e783f8 \
7 file://docs/polkit/html/license.html;md5=d85a36709a446c10f4ee123f9dda0e38"
8
9SRC_URI = "http://hal.freedesktop.org/releases/polkit-${PV}.tar.gz \
10 file://introspection.patch \
11 ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}"
12
13SRC_URI[md5sum] = "aaacf2ef18774ea8a825a426a7cfe763"
14SRC_URI[sha256sum] = "36607c8ce576980ee55bd12bab1944f13217eb8e9d04ab56022545861ece3bc5"
15
16PAM_SRC_URI = "file://polkit-1_pam.patch"
17PR = "r0"
18DEPENDS = "libpam expat dbus-glib eggdbus intltool-native"
19RDEPENDS_${PN} = "libpam"
20EXTRA_OECONF = "--with-authfw=pam --with-os-type=moblin --disable-man-pages --disable-gtk-doc --disable-introspection"
21
22inherit autotools pkgconfig
23
24FILES_${PN} += "${libdir}/${PN}-1/extensions/*.so \
25 ${datadir}/${PN}-1/actions/* \
26 ${datadir}/dbus-1/system-services/*"
27FILES_${PN}-dbg += "${libdir}/${PN}-1/extensions/.debug/*.so"
28FILES_${PN}-dev += "${libdir}/${PN}-1/extensions/*.la "
29
30do_install_append() {
31 rm -f ${D}${libdir}/${PN}-1/extensions/*.a
32}
33