summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
diff options
context:
space:
mode:
authorXin Ouyang <Xin.Ouyang@windriver.com>2012-11-30 18:29:59 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-03 16:38:35 +0000
commit5d8ddf43d22412dcaaee973b4556e9a969b6aae1 (patch)
tree792e04fd56bb24bfae213a92e66cd422b918d6fc /meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
parent07d689aa876d3cceb2bbeaa08f6dc03f778611b7 (diff)
downloadpoky-5d8ddf43d22412dcaaee973b4556e9a969b6aae1.tar.gz
libxml-sax-base-perl: add recipe for libxml-sax-perl
If libxml-sax-base-perl is not installed on the target, libxml-sax-perl would be fail to use. So add the recipe. # cat > test.pl <<-EOF #!/usr/bin/perl use XML::SAX; EOF # perl ./test.pl Can't locate XML/SAX/Exception.pm in @INC ... Also inherit allarch for three perl modules. (From OE-Core rev: 3230d943699c77f3fe9ce9d9949eae21d825186d) Signed-off-by: Xin Ouyang <Xin.Ouyang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/perl/libxml-sax-perl_0.99.bb')
-rw-r--r--meta/recipes-extended/perl/libxml-sax-perl_0.99.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb b/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
index 3a0873fe41..647cb77fa8 100644
--- a/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
+++ b/meta/recipes-extended/perl/libxml-sax-perl_0.99.bb
@@ -10,8 +10,8 @@ javaness."
10SECTION = "libs" 10SECTION = "libs"
11LICENSE = "Artistic-1.0 | GPL-1.0+" 11LICENSE = "Artistic-1.0 | GPL-1.0+"
12DEPENDS += "libxml-namespacesupport-perl-native" 12DEPENDS += "libxml-namespacesupport-perl-native"
13RDEPENDS_${PN} += "libxml-namespacesupport-perl perl-module-file-temp" 13RDEPENDS_${PN} += "libxml-namespacesupport-perl libxml-sax-base-perl perl-module-file-temp"
14PR = "r1" 14PR = "r2"
15 15
16LIC_FILES_CHKSUM = "file://LICENSE;md5=65c4cd8f39c24c7135ed70dacbcb09e3" 16LIC_FILES_CHKSUM = "file://LICENSE;md5=65c4cd8f39c24c7135ed70dacbcb09e3"
17 17
@@ -22,6 +22,6 @@ SRC_URI[sha256sum] = "32b04b8e36b6cc4cfc486de2d859d87af5386dd930f2383c49347050d6
22 22
23S = "${WORKDIR}/XML-SAX-${PV}" 23S = "${WORKDIR}/XML-SAX-${PV}"
24 24
25inherit cpan 25inherit cpan allarch
26 26
27BBCLASSEXTEND = "native" 27BBCLASSEXTEND = "native"