summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/perl/libxml-sax-base-perl_1.08.bb
diff options
context:
space:
mode:
authorXin Ouyang <Xin.Ouyang@windriver.com>2012-11-30 18:29:59 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-03 16:38:35 +0000
commit5d8ddf43d22412dcaaee973b4556e9a969b6aae1 (patch)
tree792e04fd56bb24bfae213a92e66cd422b918d6fc /meta/recipes-extended/perl/libxml-sax-base-perl_1.08.bb
parent07d689aa876d3cceb2bbeaa08f6dc03f778611b7 (diff)
downloadpoky-5d8ddf43d22412dcaaee973b4556e9a969b6aae1.tar.gz
libxml-sax-base-perl: add recipe for libxml-sax-perl
If libxml-sax-base-perl is not installed on the target, libxml-sax-perl would be fail to use. So add the recipe. # cat > test.pl <<-EOF #!/usr/bin/perl use XML::SAX; EOF # perl ./test.pl Can't locate XML/SAX/Exception.pm in @INC ... Also inherit allarch for three perl modules. (From OE-Core rev: 3230d943699c77f3fe9ce9d9949eae21d825186d) Signed-off-by: Xin Ouyang <Xin.Ouyang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/perl/libxml-sax-base-perl_1.08.bb')
-rw-r--r--meta/recipes-extended/perl/libxml-sax-base-perl_1.08.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-extended/perl/libxml-sax-base-perl_1.08.bb b/meta/recipes-extended/perl/libxml-sax-base-perl_1.08.bb
new file mode 100644
index 0000000000..d87c044119
--- /dev/null
+++ b/meta/recipes-extended/perl/libxml-sax-base-perl_1.08.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Base class SAX Drivers and Filters"
2DESCRIPTION = "This module has a very simple task - to be a base class for \
3PerlSAX drivers and filters. It's default behaviour is to pass \
4the input directly to the output unchanged. It can be useful to \
5use this module as a base class so you don't have to, for example, \
6implement the characters() callback."
7
8SECTION = "libs"
9LICENSE = "Artistic-1.0 | GPL-1.0+"
10RDEPENDS += "perl-module-extutils-makemaker"
11PR = "r0"
12
13LIC_FILES_CHKSUM = "file://dist.ini;endline=5;md5=8f9c9a55340aefaee6e9704c88466446"
14
15SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GR/GRANTM/XML-SAX-Base-${PV}.tar.gz"
16
17SRC_URI[md5sum] = "38c8c3247dfd080712596118d70dbe32"
18SRC_URI[sha256sum] = "666270318b15f88b8427e585198abbc19bc2e6ccb36dc4c0a4f2d9807330219e"
19
20S = "${WORKDIR}/XML-SAX-Base-${PV}"
21
22inherit cpan allarch
23
24BBCLASSEXTEND = "native"