summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/parted/parted_3.4.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2021-02-09 16:30:36 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-10 23:48:55 +0000
commit7a89d2d2ed0ae35bd06357c8a4155f503c7735e2 (patch)
tree5b8736dea1aca18b78820315ece4d93ed4e3fca3 /meta/recipes-extended/parted/parted_3.4.bb
parentede47ac1476bcc3769a280103ed76d6eeb668b2e (diff)
downloadpoky-7a89d2d2ed0ae35bd06357c8a4155f503c7735e2.tar.gz
parted: upgrade 3.3 -> 3.4
0001-Move-python-helper-scripts-used-only-in-tests-to-Pyt.patch 0001-libparted-fs-add-sourcedir-lib-to-include-paths.patch 0002-tests-use-skip_-rather-than-skip_test_-which-is-unde.patch removed since they are included in 3.4 Add python3-core to RDEPENDS_parted-ptest since /usr/lib/parted/ptest/tests/msdos-overlap contained in package parted-ptest requires /usr/bin/python3 (From OE-Core rev: c7d7e5f8177cdebd580ca7ff8f4412596567aff1) Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/parted/parted_3.4.bb')
-rw-r--r--meta/recipes-extended/parted/parted_3.4.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-extended/parted/parted_3.4.bb b/meta/recipes-extended/parted/parted_3.4.bb
new file mode 100644
index 0000000000..db59189fa0
--- /dev/null
+++ b/meta/recipes-extended/parted/parted_3.4.bb
@@ -0,0 +1,59 @@
1SUMMARY = "Disk partition editing/resizing utility"
2HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
3LICENSE = "GPLv3+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2f31b266d3440dd7ee50f92cf67d8e6c"
5SECTION = "console/tools"
6DEPENDS = "ncurses util-linux virtual/libiconv"
7
8SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \
9 file://no_check.patch \
10 file://fix-doc-mandir.patch \
11 file://0002-libparted_fs_resize-link-against-libuuid-explicitly-.patch \
12 file://run-ptest \
13 "
14
15SRC_URI[md5sum] = "357d19387c6e7bc4a8a90fe2d015fe80"
16SRC_URI[sha256sum] = "e1298022472da5589b7f2be1d5ee3c1b66ec3d96dfbad03dc642afd009da5342"
17
18EXTRA_OECONF = "--disable-device-mapper"
19
20inherit autotools pkgconfig gettext texinfo ptest
21
22PACKAGECONFIG ?= "readline"
23PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
24
25BBCLASSEXTEND = "native nativesdk"
26
27do_compile_ptest() {
28 oe_runmake -C tests print-align print-max dup-clobber duplicate fs-resize print-flags
29}
30
31do_install_ptest() {
32 t=${D}${PTEST_PATH}
33 mkdir $t/build-aux
34 cp ${S}/build-aux/test-driver $t/build-aux/
35 cp -r ${S}/tests $t
36 cp ${B}/tests/Makefile $t/tests/
37 sed -i "s|^VERSION.*|VERSION = ${PV}|g" $t/tests/Makefile
38 sed -i "s|^srcdir =.*|srcdir = \.|g" $t/tests/Makefile
39 sed -i "s|^abs_srcdir =.*|abs_srcdir = \.|g" $t/tests/Makefile
40 sed -i "s|^abs_top_srcdir =.*|abs_top_srcdir = \.\.|g" $t/tests/Makefile
41 sed -i "s|^Makefile:.*|Makefile:|g" $t/tests/Makefile
42 for i in print-align print-max print-flags dup-clobber duplicate fs-resize; \
43 do cp ${B}/tests/.libs/$i $t/tests/; \
44 done
45 sed -e 's| ../parted||' -i $t/tests/*.sh
46}
47
48RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3 make gawk e2fsprogs-mke2fs python3-core"
49RRECOMMENDS_${PN}-ptest = "kernel-module-scsi-debug"
50RDEPENDS_${PN}-ptest_append_libc-glibc = "\
51 glibc-utils \
52 locale-base-en-us \
53 "
54
55inherit update-alternatives
56
57ALTERNATIVE_PRIORITY = "100"
58ALTERNATIVE_${PN} = "partprobe"
59ALTERNATIVE_LINK_NAME[partprobe] = "${sbindir}/partprobe"