summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/parted/parted_3.4.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2021-07-09 12:08:47 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-10 22:42:22 +0100
commit1d452b2c090d6e582c8cf81a866d06bec1c0d040 (patch)
tree684e24fc603e19e8dc12eb8c6cfa82b17ca463a9 /meta/recipes-extended/parted/parted_3.4.bb
parente81bef685f7f3cb862bbf5aadfbcd80846f7debe (diff)
downloadpoky-1d452b2c090d6e582c8cf81a866d06bec1c0d040.tar.gz
parted: improve ptest execution
Delete the right log files in run-ptest so the tests can be executed more than once. Install config.h so the tests which examine the build configuration will do the right thing, specifically this causes the tests using libblkid to execute instead of skip. Add missing RDEPENDS: mkswap and tune2fs binaries, loop and vfat kernel modules. (From OE-Core rev: 43bd50cbf902ce92ea613d142fae2524011b8f55) Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/parted/parted_3.4.bb')
-rw-r--r--meta/recipes-extended/parted/parted_3.4.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta/recipes-extended/parted/parted_3.4.bb b/meta/recipes-extended/parted/parted_3.4.bb
index fb583489f8..4b76ca4861 100644
--- a/meta/recipes-extended/parted/parted_3.4.bb
+++ b/meta/recipes-extended/parted/parted_3.4.bb
@@ -35,10 +35,13 @@ do_install_ptest() {
35 cp ${S}/build-aux/test-driver $t/build-aux/ 35 cp ${S}/build-aux/test-driver $t/build-aux/
36 cp -r ${S}/tests $t 36 cp -r ${S}/tests $t
37 cp ${B}/tests/Makefile $t/tests/ 37 cp ${B}/tests/Makefile $t/tests/
38 mkdir $t/lib
39 cp ${B}/lib/config.h $t/lib
38 sed -i "s|^VERSION.*|VERSION = ${PV}|g" $t/tests/Makefile 40 sed -i "s|^VERSION.*|VERSION = ${PV}|g" $t/tests/Makefile
39 sed -i "s|^srcdir =.*|srcdir = \.|g" $t/tests/Makefile 41 sed -i "s|^srcdir =.*|srcdir = \.|g" $t/tests/Makefile
40 sed -i "s|^abs_srcdir =.*|abs_srcdir = \.|g" $t/tests/Makefile 42 sed -i "s|^abs_srcdir =.*|abs_srcdir = \.|g" $t/tests/Makefile
41 sed -i "s|^abs_top_srcdir =.*|abs_top_srcdir = \.\.|g" $t/tests/Makefile 43 sed -i "s|^abs_top_srcdir =.*|abs_top_srcdir = "${PTEST_PATH}"|g" $t/tests/Makefile
44 sed -i "s|^abs_top_builddir =.*|abs_top_builddir = "${PTEST_PATH}"|g" $t/tests/Makefile
42 sed -i "s|^Makefile:.*|Makefile:|g" $t/tests/Makefile 45 sed -i "s|^Makefile:.*|Makefile:|g" $t/tests/Makefile
43 sed -i "/^BUILDINFO.*$/d" $t/tests/Makefile 46 sed -i "/^BUILDINFO.*$/d" $t/tests/Makefile
44 for i in print-align print-max print-flags dup-clobber duplicate fs-resize; \ 47 for i in print-align print-max print-flags dup-clobber duplicate fs-resize; \
@@ -46,9 +49,8 @@ do_install_ptest() {
46 done 49 done
47 sed -e 's| ../parted||' -i $t/tests/*.sh 50 sed -e 's| ../parted||' -i $t/tests/*.sh
48} 51}
49 52RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup util-linux-mkswap python3 make gawk e2fsprogs-mke2fs e2fsprogs-tune2fs python3-core dosfstools"
50RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3 make gawk e2fsprogs-mke2fs python3-core dosfstools" 53RRECOMMENDS_${PN}-ptest = "kernel-module-scsi-debug kernel-module-loop kernel-module-vfat"
51RRECOMMENDS_${PN}-ptest = "kernel-module-scsi-debug"
52RDEPENDS_${PN}-ptest_append_libc-glibc = "\ 54RDEPENDS_${PN}-ptest_append_libc-glibc = "\
53 glibc-utils \ 55 glibc-utils \
54 locale-base-en-us \ 56 locale-base-en-us \