summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/parted/parted_3.1.bb
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-01-26 13:56:09 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-02 11:22:11 +0000
commitc2bb0ce67159ebc2ed9f21df0b09054e1420ec67 (patch)
tree34f46d0e1c67d45bd59ec30408bb06f7d5771ab8 /meta/recipes-extended/parted/parted_3.1.bb
parent7c66dcc5a4bbb3cdfa10fbc452d3c5be3a2fbb77 (diff)
downloadpoky-c2bb0ce67159ebc2ed9f21df0b09054e1420ec67.tar.gz
parted: enable ptest support
Install parted test suite and run it as ptest. (From OE-Core rev: 425a3fb935f40325baeff88d2519b601a87c418d) Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/parted/parted_3.1.bb')
-rw-r--r--meta/recipes-extended/parted/parted_3.1.bb25
1 files changed, 23 insertions, 2 deletions
diff --git a/meta/recipes-extended/parted/parted_3.1.bb b/meta/recipes-extended/parted/parted_3.1.bb
index 2d720270d8..1e07da4d60 100644
--- a/meta/recipes-extended/parted/parted_3.1.bb
+++ b/meta/recipes-extended/parted/parted_3.1.bb
@@ -11,13 +11,34 @@ SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \
11 file://syscalls.patch \ 11 file://syscalls.patch \
12 file://fix-git-version-gen.patch \ 12 file://fix-git-version-gen.patch \
13 file://fix-doc-mandir.patch \ 13 file://fix-doc-mandir.patch \
14 file://fix-dvh-overflows.patch" 14 file://fix-dvh-overflows.patch \
15 file://run-ptest \
16 file://Makefile \
17"
15 18
16SRC_URI[md5sum] = "5d89d64d94bcfefa9ce8f59f4b81bdcb" 19SRC_URI[md5sum] = "5d89d64d94bcfefa9ce8f59f4b81bdcb"
17SRC_URI[sha256sum] = "5e9cc1f91eaf016e5033d85b9b893fd6d3ffaca532a48de1082df9b94225ca15" 20SRC_URI[sha256sum] = "5e9cc1f91eaf016e5033d85b9b893fd6d3ffaca532a48de1082df9b94225ca15"
18 21
19EXTRA_OECONF = "--disable-device-mapper" 22EXTRA_OECONF = "--disable-device-mapper"
20 23
21inherit autotools pkgconfig gettext 24inherit autotools pkgconfig gettext ptest
22 25
23BBCLASSEXTEND = "native" 26BBCLASSEXTEND = "native"
27
28do_compile_ptest() {
29 oe_runmake -C tests print-align print-max dup-clobber duplicate fs-resize
30}
31
32do_install_ptest() {
33 t=${D}${PTEST_PATH}
34 mkdir $t/build-aux
35 cp ${S}/build-aux/test-driver $t/build-aux/
36 cp -r ${S}/tests $t
37 cp ${WORKDIR}/Makefile $t/tests/
38 for i in print-align print-max dup-clobber duplicate fs-resize; \
39 do cp ${B}/tests/.libs/$i $t/tests/; \
40 done
41 sed -e 's| ../parted||' -i $t/tests/*.sh
42}
43
44RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup"