summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/packagegroups/packagegroup-core-basic.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-03-06 16:46:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-07 14:45:21 +0000
commit91c372f287732cdedbd7c1204c6ba5f34e5b93f6 (patch)
treec088d751fdbaed6e10c58f92aa8890848c225458 /meta/recipes-extended/packagegroups/packagegroup-core-basic.bb
parent2f9bf7bc97cb832f4db13df62ce09d96ce75e810 (diff)
downloadpoky-91c372f287732cdedbd7c1204c6ba5f34e5b93f6.tar.gz
core-image-basic / packagegroup-core-basic: rename to *-full-cmdline
This more accurately represents what this image and packagegroup are intended to provide (a more complete command-line environment similar to what you would find on a traditional Linux system), and avoids confusion with the similarly named core-image-base and packagegroup-base. Fixes [YOCTO #2424]. (From OE-Core rev: 959396d5319df6d6599cc74077e85182768b92af) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/packagegroups/packagegroup-core-basic.bb')
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-basic.bb138
1 files changed, 0 insertions, 138 deletions
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-basic.bb b/meta/recipes-extended/packagegroups/packagegroup-core-basic.bb
deleted file mode 100644
index f3b4ff7f0b..0000000000
--- a/meta/recipes-extended/packagegroups/packagegroup-core-basic.bb
+++ /dev/null
@@ -1,138 +0,0 @@
1#
2# Copyright (C) 2010 Intel Corporation
3#
4
5SUMMARY = "Create Basic Image Tasks"
6PR = "r6"
7LICENSE = "MIT"
8
9inherit packagegroup
10
11PACKAGES = "\
12 packagegroup-core-basic \
13 packagegroup-core-basic-libs \
14 packagegroup-core-basic-utils \
15 packagegroup-core-basic-extended \
16 packagegroup-core-dev-utils \
17 packagegroup-core-multiuser \
18 packagegroup-core-initscripts \
19 packagegroup-core-sys-services \
20 "
21
22python __anonymous () {
23 # For backwards compatibility after rename
24 packages = d.getVar("PACKAGES", True).split()
25 for pkg in packages:
26 d.appendVar("RPROVIDES_%s" % pkg, pkg.replace("packagegroup-core", "task-core"))
27 d.appendVar("RREPLACES_%s" % pkg, pkg.replace("packagegroup-core", "task-core"))
28 d.appendVar("RCONFLICTS_%s" % pkg, pkg.replace("packagegroup-core", "task-core"))
29}
30
31
32RDEPENDS_packagegroup-core-basic = "\
33 packagegroup-core-basic-libs \
34 packagegroup-core-basic-utils \
35 packagegroup-core-basic-extended \
36 packagegroup-core-dev-utils \
37 packagegroup-core-multiuser \
38 packagegroup-core-initscripts \
39 packagegroup-core-sys-services \
40 "
41
42RDEPENDS_packagegroup-core-basic-libs = "\
43 glib-2.0 \
44 "
45
46RDEPENDS_packagegroup-core-basic-utils = "\
47 bash \
48 acl \
49 attr \
50 bc \
51 coreutils \
52 cpio \
53 e2fsprogs \
54 ed \
55 file \
56 findutils \
57 gawk \
58 gmp \
59 grep \
60 makedevs \
61 mc \
62 mc-fish \
63 mc-helpers \
64 mc-helpers-perl \
65 mc-helpers-python \
66 mktemp \
67 ncurses \
68 net-tools \
69 pax \
70 popt \
71 procps \
72 psmisc \
73 sed \
74 tar \
75 time \
76 util-linux \
77 zlib \
78 "
79
80RDEPENDS_packagegroup-core-basic-extended = "\
81 iproute2 \
82 iputils \
83 iptables \
84 module-init-tools \
85 openssl \
86 "
87
88RDEPENDS_packagegroup-core-dev-utils = "\
89 byacc \
90 diffutils \
91 m4 \
92 make \
93 patch \
94 "
95
96VIRTUAL-RUNTIME_initscripts ?= "initscripts"
97VIRTUAL-RUNTIME_init_manager ?= "sysvinit"
98VIRTUAL-RUNTIME_login_manager ?= "busybox"
99VIRTUAL-RUNTIME_syslog ?= "sysklogd"
100RDEPENDS_packagegroup-core-initscripts = "\
101 ${VIRTUAL-RUNTIME_initscripts} \
102 ${VIRTUAL-RUNTIME_init_manager} \
103 ethtool \
104 ${VIRTUAL-RUNTIME_login_manager} \
105 ${VIRTUAL-RUNTIME_syslog} \
106 "
107
108RDEPENDS_packagegroup-core-multiuser = "\
109 cracklib \
110 gzip \
111 ${@base_contains('DISTRO_FEATURES', 'pam', 'libuser', '', d)} \
112 shadow \
113 sudo \
114 "
115
116RDEPENDS_packagegroup-core-sys-services = "\
117 at \
118 bzip2 \
119 cronie \
120 dbus \
121 dbus-glib \
122 python-dbus \
123 elfutils \
124 gzip \
125 less \
126 libcap \
127 libevent \
128 lighttpd \
129 logrotate \
130 nfs-utils \
131 pciutils \
132 libpcre \
133 rpcbind \
134 sysfsutils \
135 tcp-wrappers \
136 tzdata \
137 "
138