summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/packagegroups/packagegroup-core-basic.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-04 19:05:19 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-05 17:37:14 +0100
commit38e71739d97764295713f20e87795a1c43c57e41 (patch)
treecd4a1db0922f6792592d2d95256f179625b4c46a /meta/recipes-extended/packagegroups/packagegroup-core-basic.bb
parent5084e47851fe9e1b3cabfb1dfe96f754975ce740 (diff)
downloadpoky-38e71739d97764295713f20e87795a1c43c57e41.tar.gz
packagegroup-(base|core-basic): add RREPLACES/RCONFLICTS
These are needed to support upgrading from task-* to packagegroup-* within existing target images at runtime. Note: these settings will very likely be moved to a separate inc file at some point in the future. (From OE-Core rev: 1b07bd4c6b1ff70267b97f94b25026a8f8ad3314) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/packagegroups/packagegroup-core-basic.bb')
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-basic.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-basic.bb b/meta/recipes-extended/packagegroups/packagegroup-core-basic.bb
index 30b66c5b4c..d3eeeedc93 100644
--- a/meta/recipes-extended/packagegroups/packagegroup-core-basic.bb
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-basic.bb
@@ -3,7 +3,7 @@
3# 3#
4 4
5DESCRIPTION = "Create Basic Image Tasks" 5DESCRIPTION = "Create Basic Image Tasks"
6PR = "r4" 6PR = "r5"
7LICENSE = "MIT" 7LICENSE = "MIT"
8 8
9inherit packagegroup 9inherit packagegroup
@@ -24,6 +24,8 @@ python __anonymous () {
24 packages = d.getVar("PACKAGES", True).split() 24 packages = d.getVar("PACKAGES", True).split()
25 for pkg in packages: 25 for pkg in packages:
26 d.appendVar("RPROVIDES_%s" % pkg, pkg.replace("packagegroup-core", "task-core")) 26 d.appendVar("RPROVIDES_%s" % pkg, pkg.replace("packagegroup-core", "task-core"))
27 d.appendVar("RREPLACES_%s" % pkg, pkg.replace("packagegroup-core", "task-core"))
28 d.appendVar("RCONFLICTS_%s" % pkg, pkg.replace("packagegroup-core", "task-core"))
27} 29}
28 30
29 31