summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt_0.52.20.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2019-08-09 09:48:37 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-13 09:37:37 +0100
commitd1100db5eb6ae18339dd7944cf9c52238790247b (patch)
tree80a8d2549964fb0e01be0dc999caf370cc3b1d9f /meta/recipes-extended/newt/libnewt_0.52.20.bb
parentd90fb2a87e69df8bdba07227f7a876c501ad93bf (diff)
downloadpoky-d1100db5eb6ae18339dd7944cf9c52238790247b.tar.gz
libnewt:upgrade 0.52.20 -> 0.52.21
-Refresh the following patch: files/pie-flags.patch -files/fix_SHAREDDIR.patch Removed since this is included in 0.52.21. (From OE-Core rev: 5b7fd7a945f8eeece51f01ad20a6de12fea89433) Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/newt/libnewt_0.52.20.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.20.bb59
1 files changed, 0 insertions, 59 deletions
diff --git a/meta/recipes-extended/newt/libnewt_0.52.20.bb b/meta/recipes-extended/newt/libnewt_0.52.20.bb
deleted file mode 100644
index dc07a1809e..0000000000
--- a/meta/recipes-extended/newt/libnewt_0.52.20.bb
+++ /dev/null
@@ -1,59 +0,0 @@
1SUMMARY = "A library for text mode user interfaces"
2
3DESCRIPTION = "Newt is a programming library for color text mode, widget based user \
4interfaces. Newt can be used to add stacked windows, entry widgets, \
5checkboxes, radio buttons, labels, plain text fields, scrollbars, \
6etc., to text mode user interfaces. This package also contains the \
7shared library needed by programs built with newt, as well as a \
8/usr/bin/dialog replacement called whiptail. Newt is based on the \
9slang library."
10
11HOMEPAGE = "https://releases.pagure.org/newt/"
12SECTION = "libs"
13
14LICENSE = "LGPLv2"
15LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
16
17# slang needs to be >= 2.2
18DEPENDS = "slang popt python3"
19
20SRC_URI = "https://releases.pagure.org/newt/newt-${PV}.tar.gz \
21 file://fix_SHAREDDIR.patch \
22 file://cross_ar.patch \
23 file://Makefile.in-Add-tinfo-library-to-the-linking-librari.patch \
24 file://pie-flags.patch \
25 file://0001-detect-gold-as-GNU-linker-too.patch \
26"
27
28SRC_URI[md5sum] = "70b288f821234593a8e7920e435b259b"
29SRC_URI[sha256sum] = "8d66ba6beffc3f786d4ccfee9d2b43d93484680ef8db9397a4fb70b5adbb6dbc"
30
31S = "${WORKDIR}/newt-${PV}"
32
33inherit autotools-brokensep python3native python3-dir
34
35EXTRA_OECONF = "--without-tcl --with-python"
36
37EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}"
38
39CLEANBROKEN = "1"
40
41export CPPFLAGS
42
43PACKAGES_prepend = "whiptail ${PN}-python "
44
45RDEPENDS_${PN}-python += "python3-core"
46FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
47
48do_configure_prepend() {
49 sh autogen.sh
50}
51
52do_compile_prepend() {
53 # Make sure the recompile is OK
54 rm -f ${B}/.depend
55}
56
57FILES_whiptail = "${bindir}/whiptail"
58
59BBCLASSEXTEND = "native nativesdk"