summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt_0.52.20.bb
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2017-05-15 11:20:27 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-23 11:44:13 +0100
commita16d0f6c496f4c8c61accbabd6769839bda62f36 (patch)
tree04aada50d94ba42d5a0807145cbaddcc4aff963c /meta/recipes-extended/newt/libnewt_0.52.20.bb
parent85f8fc1f503cf901c4e258f40936666445b3fed8 (diff)
downloadpoky-a16d0f6c496f4c8c61accbabd6769839bda62f36.tar.gz
libnewt: 0.52.19 -> 0.52.20
Upgrade libnewt from 0.52.19 to 0.52.20. (From OE-Core rev: a83715c10536904db1d274bfb3faf87a1b3d19bc) Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/newt/libnewt_0.52.20.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.20.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt_0.52.20.bb b/meta/recipes-extended/newt/libnewt_0.52.20.bb
new file mode 100644
index 0000000000..65ce70c47d
--- /dev/null
+++ b/meta/recipes-extended/newt/libnewt_0.52.20.bb
@@ -0,0 +1,54 @@
1SUMMARY = "A library for text mode user interfaces"
2
3DESCRIPTION = "Newt is a programming library for color text mode, widget based user \
4interfaces. Newt can be used to add stacked windows, entry widgets, \
5checkboxes, radio buttons, labels, plain text fields, scrollbars, \
6etc., to text mode user interfaces. This package also contains the \
7shared library needed by programs built with newt, as well as a \
8/usr/bin/dialog replacement called whiptail. Newt is based on the \
9slang library."
10
11HOMEPAGE = "https://releases.pagure.org/newt/"
12SECTION = "libs"
13
14LICENSE = "LGPLv2"
15LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
16
17# slang needs to be >= 2.2
18DEPENDS = "slang popt"
19
20SRC_URI = "https://releases.pagure.org/newt/newt-${PV}.tar.gz \
21 file://fix_SHAREDDIR.patch \
22 file://cross_ar.patch \
23 file://Makefile.in-Add-tinfo-library-to-the-linking-librari.patch \
24 file://pie-flags.patch \
25 file://0001-detect-gold-as-GNU-linker-too.patch \
26"
27
28SRC_URI[md5sum] = "70b288f821234593a8e7920e435b259b"
29SRC_URI[sha256sum] = "8d66ba6beffc3f786d4ccfee9d2b43d93484680ef8db9397a4fb70b5adbb6dbc"
30
31S = "${WORKDIR}/newt-${PV}"
32
33EXTRA_OECONF = "--without-tcl --without-python"
34
35inherit autotools-brokensep
36
37CLEANBROKEN = "1"
38
39export CPPFLAGS
40
41PACKAGES_prepend = "whiptail "
42
43do_configure_prepend() {
44 sh autogen.sh
45}
46
47do_compile_prepend() {
48 # Make sure the recompile is OK
49 rm -f ${B}/.depend
50}
51
52FILES_whiptail = "${bindir}/whiptail"
53
54BBCLASSEXTEND = "native"