summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt_0.52.18.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-11-25 11:25:36 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-03 12:23:57 +0000
commitec6aeeada775c032d27f70d47eb5859b3e9bc220 (patch)
tree385877c54c42188e2c0c5e7dd9ba2fb9e024d537 /meta/recipes-extended/newt/libnewt_0.52.18.bb
parent4b938a676b59deeac7b62d100c205c06098f4df9 (diff)
downloadpoky-ec6aeeada775c032d27f70d47eb5859b3e9bc220.tar.gz
libnewt/libnewt-python: upgrade to 0.52.18
(From OE-Core rev: 5239060e99da82134387787e544e724500a6ab41) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/newt/libnewt_0.52.18.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.18.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt_0.52.18.bb b/meta/recipes-extended/newt/libnewt_0.52.18.bb
new file mode 100644
index 0000000000..e8ac66269a
--- /dev/null
+++ b/meta/recipes-extended/newt/libnewt_0.52.18.bb
@@ -0,0 +1,52 @@
1SUMMARY = "A library for text mode user interfaces"
2
3DESCRIPTION = "Newt is a programming library for color text mode, widget based user \
4interfaces. Newt can be used to add stacked windows, entry widgets, \
5checkboxes, radio buttons, labels, plain text fields, scrollbars, \
6etc., to text mode user interfaces. This package also contains the \
7shared library needed by programs built with newt, as well as a \
8/usr/bin/dialog replacement called whiptail. Newt is based on the \
9slang library."
10
11HOMEPAGE = "https://fedorahosted.org/newt/"
12SECTION = "libs"
13
14LICENSE = "LGPLv2"
15LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
16
17# slang needs to be >= 2.2
18DEPENDS = "slang popt"
19
20SRC_URI = "https://fedorahosted.org/releases/n/e/newt/newt-${PV}.tar.gz \
21 file://remove_slang_include.patch \
22 file://fix_SHAREDDIR.patch \
23 file://cross_ar.patch \
24"
25
26SRC_URI[md5sum] = "685721bee1a318570704b19dcf31d268"
27SRC_URI[sha256sum] = "771b0e634ede56ae6a6acd910728bb5832ac13ddb0d1d27919d2498dab70c91e"
28
29S = "${WORKDIR}/newt-${PV}"
30
31EXTRA_OECONF = "--without-tcl --without-python"
32
33inherit autotools-brokensep
34
35export STAGING_INCDIR
36export STAGING_LIBDIR
37
38export BUILD_SYS
39export HOST_SYS
40
41PACKAGES_prepend = "whiptail "
42
43do_configure_prepend() {
44 sh autogen.sh
45}
46
47do_compile_prepend() {
48 # Make sure the recompile is OK
49 rm -f ${B}/.depend
50}
51
52FILES_whiptail = "${bindir}/whiptail"