summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt_0.52.14.bb
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2013-06-05 16:38:55 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-13 17:38:05 +0100
commit9013f8165301abeed0e87184e9b820e72f1c4efe (patch)
treefb4c7e2c9c5f1cda6fec72c2892da352bd679473 /meta/recipes-extended/newt/libnewt_0.52.14.bb
parent670c6514519f5497229719ddb32a2dbb57494f6c (diff)
downloadpoky-9013f8165301abeed0e87184e9b820e72f1c4efe.tar.gz
libnewt: split python module into libnewt-python
This is useful as it avoids pulling python into a build just to build chkconfig. The python recipe uses the libnewt installed in the sysroot by the main package, so there's little loss of build time, other than the additional unpack/patch. (From OE-Core rev: b255ebbf8283568d732827086bf0bd2b8db1d905) Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/newt/libnewt_0.52.14.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.14.bb15
1 files changed, 5 insertions, 10 deletions
diff --git a/meta/recipes-extended/newt/libnewt_0.52.14.bb b/meta/recipes-extended/newt/libnewt_0.52.14.bb
index 54da15df34..ee8206e4b4 100644
--- a/meta/recipes-extended/newt/libnewt_0.52.14.bb
+++ b/meta/recipes-extended/newt/libnewt_0.52.14.bb
@@ -15,7 +15,7 @@ LICENSE = "LGPLv2"
15LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605" 15LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
16 16
17# slang needs to be >= 2.2 17# slang needs to be >= 2.2
18DEPENDS = "slang popt python" 18DEPENDS = "slang popt"
19 19
20PR = "r2" 20PR = "r2"
21 21
@@ -30,11 +30,9 @@ SRC_URI[sha256sum] = "f70f4f58baa60388ddf2e39249ffb00898fb40f2b2767e42e2ab51fe4b
30 30
31S = "${WORKDIR}/newt-${PV}" 31S = "${WORKDIR}/newt-${PV}"
32 32
33EXTRA_OECONF = "--without-tcl" 33EXTRA_OECONF = "--without-tcl --without-python"
34 34
35inherit autotools pythonnative python-dir 35inherit autotools
36
37EXTRA_OEMAKE = "PYTHONVERS=${PYTHON_DIR}"
38 36
39export STAGING_INCDIR 37export STAGING_INCDIR
40export STAGING_LIBDIR 38export STAGING_LIBDIR
@@ -42,13 +40,10 @@ export STAGING_LIBDIR
42export BUILD_SYS 40export BUILD_SYS
43export HOST_SYS 41export HOST_SYS
44 42
45PACKAGES_prepend = "whiptail ${PN}-python " 43PACKAGES_prepend = "whiptail "
46 44
47do_configure_prepend() { 45do_configure_prepend() {
48 ( cd ${S}; sh autogen.sh ) 46 sh autogen.sh
49} 47}
50 48
51FILES_whiptail = "${bindir}/whiptail" 49FILES_whiptail = "${bindir}/whiptail"
52FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug/"
53FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
54FILES_${PN}-staticdev = "${libdir}/*.a"