summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt-python_0.52.20.bb
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2017-05-15 11:20:27 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-23 11:44:13 +0100
commita16d0f6c496f4c8c61accbabd6769839bda62f36 (patch)
tree04aada50d94ba42d5a0807145cbaddcc4aff963c /meta/recipes-extended/newt/libnewt-python_0.52.20.bb
parent85f8fc1f503cf901c4e258f40936666445b3fed8 (diff)
downloadpoky-a16d0f6c496f4c8c61accbabd6769839bda62f36.tar.gz
libnewt: 0.52.19 -> 0.52.20
Upgrade libnewt from 0.52.19 to 0.52.20. (From OE-Core rev: a83715c10536904db1d274bfb3faf87a1b3d19bc) Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/newt/libnewt-python_0.52.20.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt-python_0.52.20.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt-python_0.52.20.bb b/meta/recipes-extended/newt/libnewt-python_0.52.20.bb
new file mode 100644
index 0000000000..20369effeb
--- /dev/null
+++ b/meta/recipes-extended/newt/libnewt-python_0.52.20.bb
@@ -0,0 +1,28 @@
1require recipes-extended/newt/libnewt_${PV}.bb
2
3SUMMARY .= " - python"
4DEPENDS = "libnewt python3"
5RDEPENDS_${PN} += "python3-core"
6
7inherit python3native python3-dir
8
9EXTRA_OECONF += "--with-python"
10EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}"
11
12
13do_compile () {
14 VERSION="$(sed -n 's/^VERSION = //p' Makefile)"
15 oe_runmake _snack.so
16}
17
18do_install () {
19 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
20 install -m 0755 ${PYTHON_DIR}/_snack.so ${D}${PYTHON_SITEPACKAGES_DIR}/
21 install -m 0644 snack.py ${D}${PYTHON_SITEPACKAGES_DIR}/
22}
23
24PACKAGES_remove = "whiptail"
25
26FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/*"
27
28BBCLASSEXTEND = "native"