summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt-python_0.52.17.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-06-17 15:01:05 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-17 17:56:21 +0100
commitcb25932e731c212d059548bec727917b6d32ece5 (patch)
tree3916e12643810c26d0267b6aa25fca06a3d080a4 /meta/recipes-extended/newt/libnewt-python_0.52.17.bb
parent55c85889811c769aa841bd74b43294e1f982368f (diff)
downloadpoky-cb25932e731c212d059548bec727917b6d32ece5.tar.gz
libnewt/libnewt-python: upgrade to 0.52.17
- The company address has changed in COPYING. - Rebase fix_SHAREDDIR.patch to 0.52.17 - Rebase cross_ar.patch to 0.52.17 - Obsolete fix_python_fpic.patch, since the patch has been merged by upstream; - The upstream rename snackmodule to snack in 0.52.17, so tweak libnewt-python_0.52.17.bb; (From OE-Core rev: 46ec6e5601b88d4270d58586f25626349474d769) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/newt/libnewt-python_0.52.17.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt-python_0.52.17.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt-python_0.52.17.bb b/meta/recipes-extended/newt/libnewt-python_0.52.17.bb
new file mode 100644
index 0000000000..d591fbd3d2
--- /dev/null
+++ b/meta/recipes-extended/newt/libnewt-python_0.52.17.bb
@@ -0,0 +1,27 @@
1require recipes-extended/newt/libnewt_${PV}.bb
2
3SUMMARY .= " - python"
4DEPENDS = "libnewt python"
5RDEPENDS_${PN} += "python-core"
6
7inherit pythonnative python-dir
8
9EXTRA_OECONF += "--with-python"
10EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}"
11
12
13do_compile () {
14 VERSION="$(sed -n 's/^VERSION = //p' Makefile)"
15 oe_runmake "LIBNEWTSH=${STAGING_LIBDIR}/libnewt.so.$VERSION" _snack.so
16}
17
18do_install () {
19 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
20 install -m 0755 ${PYTHON_DIR}/_snack.so ${D}${PYTHON_SITEPACKAGES_DIR}/
21 install -m 0644 snack.py ${D}${PYTHON_SITEPACKAGES_DIR}/
22}
23
24PACKAGES_remove = "whiptail"
25
26FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/*"
27FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug/"