summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/mdadm_4.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-08 12:56:02 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-09 11:08:11 +0000
commitd47e89f338992b626d052b9c7e24d9ea9076b689 (patch)
treef568361a9ed2b302475d4d6745c1d593b4bae587 /meta/recipes-extended/mdadm/mdadm_4.1.bb
parent55553c2477c353994d458a9680737f9af2590571 (diff)
downloadpoky-d47e89f338992b626d052b9c7e24d9ea9076b689.tar.gz
mdadm: Drop redundant patches and fix build with clang
Several patches were being applied unnecessarily, the purpose they served at one point has either been fixed differently, or accepted upstream. Add a new patch to make clang's diagnostics happy (From OE-Core rev: 8bc0d2f2197430723f8b2d0785169e48c883eedb) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_4.1.bb')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_4.1.bb20
1 files changed, 9 insertions, 11 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_4.1.bb b/meta/recipes-extended/mdadm/mdadm_4.1.bb
index b9f55841cb..9118baaf1a 100644
--- a/meta/recipes-extended/mdadm/mdadm_4.1.bb
+++ b/meta/recipes-extended/mdadm/mdadm_4.1.bb
@@ -9,24 +9,21 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
9 9
10 10
11SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.xz \ 11SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.xz \
12 file://gcc-4.9.patch \ 12 file://run-ptest \
13 file://mdadm-3.3.2_x32_abi_time_t.patch \ 13 file://mdadm-3.3.2_x32_abi_time_t.patch \
14 file://mdadm-fix-ptest-build-errors.patch \ 14 file://mdadm-fix-ptest-build-errors.patch \
15 file://0001-Fix-the-path-of-corosync-and-dlm-header-files-check.patch \
16 file://run-ptest \
17 file://0001-mdadm.h-Undefine-dprintf-before-redefining.patch \ 15 file://0001-mdadm.h-Undefine-dprintf-before-redefining.patch \
18 file://0001-include-sys-sysmacros.h-for-major-minor-defintions.patch \ 16 file://0001-Fix-the-path-of-corosync-and-dlm-header-files-check.patch \
19 file://0005-Add-a-comment-to-indicate-valid-fallthrough.patch \
20 file://0001-Use-CC-to-check-for-implicit-fallthrough-warning-sup.patch \ 17 file://0001-Use-CC-to-check-for-implicit-fallthrough-warning-sup.patch \
21 file://0001-Disable-gcc8-warnings.patch \ 18 file://0001-Compute-abs-diff-in-a-standard-compliant-way.patch \
22 " 19 "
23SRC_URI[md5sum] = "51bf3651bd73a06c413a2f964f299598" 20SRC_URI[md5sum] = "51bf3651bd73a06c413a2f964f299598"
24SRC_URI[sha256sum] = "ab7688842908d3583a704d491956f31324c3a5fc9f6a04653cb75d19f1934f4a" 21SRC_URI[sha256sum] = "ab7688842908d3583a704d491956f31324c3a5fc9f6a04653cb75d19f1934f4a"
25 22
26CFLAGS += "-fno-strict-aliasing" 23inherit autotools-brokensep ptest
27inherit autotools-brokensep 24
25CFLAGS_append_toolchain-clang = " -Wno-error=address-of-packed-member"
28 26
29EXTRA_OEMAKE = 'CHECK_RUN_DIR=0 CXFLAGS="${CFLAGS}"'
30# PPC64 and MIPS64 uses long long for u64 in the kernel, but powerpc's asm/types.h 27# PPC64 and MIPS64 uses long long for u64 in the kernel, but powerpc's asm/types.h
31# prevents 64-bit userland from seeing this definition, instead defaulting 28# prevents 64-bit userland from seeing this definition, instead defaulting
32# to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get 29# to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get
@@ -35,6 +32,8 @@ CFLAGS_append_powerpc64 = ' -D__SANE_USERSPACE_TYPES__'
35CFLAGS_append_mipsarchn64 = ' -D__SANE_USERSPACE_TYPES__' 32CFLAGS_append_mipsarchn64 = ' -D__SANE_USERSPACE_TYPES__'
36CFLAGS_append_mipsarchn32 = ' -D__SANE_USERSPACE_TYPES__' 33CFLAGS_append_mipsarchn32 = ' -D__SANE_USERSPACE_TYPES__'
37 34
35EXTRA_OEMAKE = 'CHECK_RUN_DIR=0 CXFLAGS="${CFLAGS}"'
36
38do_compile() { 37do_compile() {
39 # Point to right sbindir 38 # Point to right sbindir
40 sed -i -e "s;BINDIR = /sbin;BINDIR = $base_sbindir;" -e "s;UDEVDIR = /lib;UDEVDIR = $nonarch_base_libdir;" ${S}/Makefile 39 sed -i -e "s;BINDIR = /sbin;BINDIR = $base_sbindir;" -e "s;UDEVDIR = /lib;UDEVDIR = $nonarch_base_libdir;" ${S}/Makefile
@@ -46,8 +45,6 @@ do_install() {
46 autotools_do_install 45 autotools_do_install
47} 46}
48 47
49inherit ptest
50
51do_compile_ptest() { 48do_compile_ptest() {
52 oe_runmake test 49 oe_runmake test
53} 50}
@@ -62,6 +59,7 @@ do_install_ptest() {
62 install -D -m 755 $prg ${D}${PTEST_PATH}/ 59 install -D -m 755 $prg ${D}${PTEST_PATH}/
63 done 60 done
64} 61}
62
65RDEPENDS_${PN}-ptest += "bash" 63RDEPENDS_${PN}-ptest += "bash"
66RRECOMMENDS_${PN}-ptest += " \ 64RRECOMMENDS_${PN}-ptest += " \
67 coreutils \ 65 coreutils \