summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/mdadm_4.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-01-09 23:27:25 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-01-11 10:53:44 +0000
commitb93bd0e85ec9e5646e08639771e8d787820df8f8 (patch)
tree8ba72528c9369573eca192e646baf4e49595c198 /meta/recipes-extended/mdadm/mdadm_4.1.bb
parent633b403b6db40cf1a88a4e952615c03f290227ea (diff)
downloadpoky-b93bd0e85ec9e5646e08639771e8d787820df8f8.tar.gz
mdadm: update 4.1 -> 4.2
Drop 0001-Compute-abs-diff-in-a-standard-compliant-way.patch (upstream refactored code) mdadm-fix-ptest-build-errors.patch (upstream fixed the issue) (From OE-Core rev: acf82e36996c082f52c02d50b06965f74ef87430) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_4.1.bb')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_4.1.bb108
1 files changed, 0 insertions, 108 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_4.1.bb b/meta/recipes-extended/mdadm/mdadm_4.1.bb
deleted file mode 100644
index 35535aef86..0000000000
--- a/meta/recipes-extended/mdadm/mdadm_4.1.bb
+++ /dev/null
@@ -1,108 +0,0 @@
1SUMMARY = "Tool for managing software RAID under Linux"
2HOMEPAGE = "http://www.kernel.org/pub/linux/utils/raid/mdadm/"
3DESCRIPTION = "mdadm is a Linux utility used to manage and monitor software RAID devices."
4
5# Some files are GPLv2+ while others are GPLv2.
6LICENSE = "GPLv2 & GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
9 file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
10
11
12SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.xz \
13 file://run-ptest \
14 file://mdadm-3.3.2_x32_abi_time_t.patch \
15 file://mdadm-fix-ptest-build-errors.patch \
16 file://0001-mdadm.h-Undefine-dprintf-before-redefining.patch \
17 file://0001-Fix-the-path-of-corosync-and-dlm-header-files-check.patch \
18 file://0001-Use-CC-to-check-for-implicit-fallthrough-warning-sup.patch \
19 file://0001-Compute-abs-diff-in-a-standard-compliant-way.patch \
20 file://0001-fix-gcc-8-format-truncation-warning.patch \
21 file://debian-no-Werror.patch \
22 file://0001-Revert-tests-wait-for-complete-rebuild-in-integrity-.patch \
23 file://mdadm.init \
24 file://0001-mdadm-add-option-y-for-use-syslog-to-recive-event-re.patch \
25 file://include_sysmacros.patch \
26 file://0001-mdadm-skip-test-11spare-migration.patch \
27 "
28
29SRC_URI[md5sum] = "51bf3651bd73a06c413a2f964f299598"
30SRC_URI[sha256sum] = "ab7688842908d3583a704d491956f31324c3a5fc9f6a04653cb75d19f1934f4a"
31
32inherit autotools-brokensep ptest systemd
33
34SYSTEMD_SERVICE:${PN} = "mdmonitor.service"
35SYSTEMD_AUTO_ENABLE = "disable"
36
37CFLAGS:append:toolchain-clang = " -Wno-error=address-of-packed-member"
38
39# PPC64 and MIPS64 uses long long for u64 in the kernel, but powerpc's asm/types.h
40# prevents 64-bit userland from seeing this definition, instead defaulting
41# to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get
42# int-ll64.h included
43CFLAGS:append:powerpc64 = ' -D__SANE_USERSPACE_TYPES__'
44CFLAGS:append:mipsarchn64 = ' -D__SANE_USERSPACE_TYPES__'
45CFLAGS:append:mipsarchn32 = ' -D__SANE_USERSPACE_TYPES__'
46
47EXTRA_OEMAKE = 'CHECK_RUN_DIR=0 CXFLAGS="${CFLAGS}" SYSTEMD_DIR=${systemd_system_unitdir} \
48 BINDIR="${base_sbindir}" UDEVDIR="${nonarch_base_libdir}/udev"'
49
50DEBUG_OPTIMIZATION:append = " -Wno-error"
51
52do_compile() {
53 oe_runmake SYSROOT="${STAGING_DIR_TARGET}"
54}
55
56do_install() {
57 export STRIP=""
58 autotools_do_install
59}
60
61do_install:append() {
62 install -d ${D}/${sysconfdir}/
63 install -m 644 ${S}/mdadm.conf-example ${D}${sysconfdir}/mdadm.conf
64 install -d ${D}/${sysconfdir}/init.d
65 install -m 755 ${WORKDIR}/mdadm.init ${D}${sysconfdir}/init.d/mdmonitor
66}
67
68do_install:append() {
69 oe_runmake install-systemd DESTDIR=${D}
70}
71
72do_compile_ptest() {
73 oe_runmake test
74}
75
76do_install_ptest() {
77 cp -R --no-dereference --preserve=mode,links -v ${S}/tests ${D}${PTEST_PATH}/tests
78 cp ${S}/test ${D}${PTEST_PATH}
79 sed -e 's!sleep 0.*!sleep 1!g; s!/var/tmp!/mdadm-testing-dir!g' -i ${D}${PTEST_PATH}/test
80 sed -e 's!/var/tmp!/mdadm-testing-dir!g' -i ${D}${PTEST_PATH}/tests/*
81 sed -i -e '/echo -ne "$_script... "/d' \
82 -e 's/echo "succeeded"/echo -e "PASS: $_script"/g' \
83 -e '/save_log fail/N; /_fail=1/i\\t\t\techo -ne "FAIL: $_script"' \
84 -e '/die "dmesg prints errors when testing $_basename!"/i\\t\t\t\techo -ne "FAIL: $_script" &&' \
85 ${D}${PTEST_PATH}/test
86
87 chmod +x ${D}${PTEST_PATH}/test
88
89 ln -s ${base_sbindir}/mdadm ${D}${PTEST_PATH}/mdadm
90 for prg in test_stripe swap_super raid6check
91 do
92 install -D -m 755 $prg ${D}${PTEST_PATH}/
93 done
94}
95
96RDEPENDS:${PN}-ptest += "bash e2fsprogs-mke2fs"
97RRECOMMENDS:${PN}-ptest += " \
98 coreutils \
99 util-linux \
100 kernel-module-loop \
101 kernel-module-linear \
102 kernel-module-raid0 \
103 kernel-module-raid1 \
104 kernel-module-raid10 \
105 kernel-module-raid456 \
106"
107
108FILES:${PN} += "${systemd_unitdir}/*"