summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/mdadm_4.1.bb
diff options
context:
space:
mode:
authorMingli Yu <Mingli.Yu@windriver.com>2018-11-21 23:49:49 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-23 23:35:18 +0000
commit55d59d3f6dfaab5de9995f7ffc1a65196aadc019 (patch)
tree6f5cfbc1366ed935e2efc9e894b1eef14c637229 /meta/recipes-extended/mdadm/mdadm_4.1.bb
parentc4f4c5347c7f1300f30deee11072be09f22aee3d (diff)
downloadpoky-55d59d3f6dfaab5de9995f7ffc1a65196aadc019.tar.gz
mdadm: Upgrade to 4.1
* Remove 5 backported patches * Refresh patches to remove fuzz warnings (From OE-Core rev: a455616df65f1e9dac5e283a9cda047868465d23) Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_4.1.bb')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_4.1.bb75
1 files changed, 75 insertions, 0 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_4.1.bb b/meta/recipes-extended/mdadm/mdadm_4.1.bb
new file mode 100644
index 0000000000..b9f55841cb
--- /dev/null
+++ b/meta/recipes-extended/mdadm/mdadm_4.1.bb
@@ -0,0 +1,75 @@
1SUMMARY = "Tool for managing software RAID under Linux"
2HOMEPAGE = "http://www.kernel.org/pub/linux/utils/raid/mdadm/"
3
4# Some files are GPLv2+ while others are GPLv2.
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
8 file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
9
10
11SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.xz \
12 file://gcc-4.9.patch \
13 file://mdadm-3.3.2_x32_abi_time_t.patch \
14 file://mdadm-fix-ptest-build-errors.patch \
15 file://0001-Fix-the-path-of-corosync-and-dlm-header-files-check.patch \
16 file://run-ptest \
17 file://0001-mdadm.h-Undefine-dprintf-before-redefining.patch \
18 file://0001-include-sys-sysmacros.h-for-major-minor-defintions.patch \
19 file://0005-Add-a-comment-to-indicate-valid-fallthrough.patch \
20 file://0001-Use-CC-to-check-for-implicit-fallthrough-warning-sup.patch \
21 file://0001-Disable-gcc8-warnings.patch \
22 "
23SRC_URI[md5sum] = "51bf3651bd73a06c413a2f964f299598"
24SRC_URI[sha256sum] = "ab7688842908d3583a704d491956f31324c3a5fc9f6a04653cb75d19f1934f4a"
25
26CFLAGS += "-fno-strict-aliasing"
27inherit autotools-brokensep
28
29EXTRA_OEMAKE = 'CHECK_RUN_DIR=0 CXFLAGS="${CFLAGS}"'
30# PPC64 and MIPS64 uses long long for u64 in the kernel, but powerpc's asm/types.h
31# prevents 64-bit userland from seeing this definition, instead defaulting
32# to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get
33# int-ll64.h included
34CFLAGS_append_powerpc64 = ' -D__SANE_USERSPACE_TYPES__'
35CFLAGS_append_mipsarchn64 = ' -D__SANE_USERSPACE_TYPES__'
36CFLAGS_append_mipsarchn32 = ' -D__SANE_USERSPACE_TYPES__'
37
38do_compile() {
39 # Point to right sbindir
40 sed -i -e "s;BINDIR = /sbin;BINDIR = $base_sbindir;" -e "s;UDEVDIR = /lib;UDEVDIR = $nonarch_base_libdir;" ${S}/Makefile
41 oe_runmake SYSROOT="${STAGING_DIR_TARGET}"
42}
43
44do_install() {
45 export STRIP=""
46 autotools_do_install
47}
48
49inherit ptest
50
51do_compile_ptest() {
52 oe_runmake test
53}
54
55do_install_ptest() {
56 cp -R --no-dereference --preserve=mode,links -v ${S}/tests ${D}${PTEST_PATH}/tests
57 cp ${S}/test ${D}${PTEST_PATH}
58 sed -e 's!sleep 0.*!sleep 1!g; s!/var/tmp!/!g' -i ${D}${PTEST_PATH}/test
59 ln -s ${base_sbindir}/mdadm ${D}${PTEST_PATH}/mdadm
60 for prg in test_stripe swap_super raid6check
61 do
62 install -D -m 755 $prg ${D}${PTEST_PATH}/
63 done
64}
65RDEPENDS_${PN}-ptest += "bash"
66RRECOMMENDS_${PN}-ptest += " \
67 coreutils \
68 util-linux \
69 kernel-module-loop \
70 kernel-module-linear \
71 kernel-module-raid0 \
72 kernel-module-raid1 \
73 kernel-module-raid10 \
74 kernel-module-raid456 \
75"