summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/mdadm_4.1.bb
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2019-02-21 14:06:27 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-25 10:43:06 +0000
commit366fe3d01e623f30b81f3224dc556af8c778fc48 (patch)
tree21bdfb9ae5a57a9ade3e86490ca6acfbc4b6a1b3 /meta/recipes-extended/mdadm/mdadm_4.1.bb
parente34b0865c7deee5fac286ac076ebcbd529005247 (diff)
downloadpoky-366fe3d01e623f30b81f3224dc556af8c778fc48.tar.gz
mdadm: add init and service scripts
Add init script and service file for sysvinit and systemd. (From OE-Core rev: a6222a41c54fb9feebb980e57bcc8a572f93acd1) Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Hong Liu <hongl.fnst@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_4.1.bb')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_4.1.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_4.1.bb b/meta/recipes-extended/mdadm/mdadm_4.1.bb
index 7663a6b7ec..2d7ade68c5 100644
--- a/meta/recipes-extended/mdadm/mdadm_4.1.bb
+++ b/meta/recipes-extended/mdadm/mdadm_4.1.bb
@@ -17,11 +17,16 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.xz \
17 file://0001-Use-CC-to-check-for-implicit-fallthrough-warning-sup.patch \ 17 file://0001-Use-CC-to-check-for-implicit-fallthrough-warning-sup.patch \
18 file://0001-Compute-abs-diff-in-a-standard-compliant-way.patch \ 18 file://0001-Compute-abs-diff-in-a-standard-compliant-way.patch \
19 file://0001-fix-gcc-8-format-truncation-warning.patch \ 19 file://0001-fix-gcc-8-format-truncation-warning.patch \
20 file://mdadm.init \
21 file://mdmonitor.service \
20 " 22 "
21SRC_URI[md5sum] = "51bf3651bd73a06c413a2f964f299598" 23SRC_URI[md5sum] = "51bf3651bd73a06c413a2f964f299598"
22SRC_URI[sha256sum] = "ab7688842908d3583a704d491956f31324c3a5fc9f6a04653cb75d19f1934f4a" 24SRC_URI[sha256sum] = "ab7688842908d3583a704d491956f31324c3a5fc9f6a04653cb75d19f1934f4a"
23 25
24inherit autotools-brokensep ptest 26inherit autotools-brokensep ptest systemd
27
28SYSTEMD_SERVICE_${PN} = "mdmonitor.service"
29SYSTEMD_AUTO_ENABLE = "disable"
25 30
26CFLAGS_append_toolchain-clang = " -Wno-error=address-of-packed-member" 31CFLAGS_append_toolchain-clang = " -Wno-error=address-of-packed-member"
27 32
@@ -46,6 +51,15 @@ do_install() {
46 autotools_do_install 51 autotools_do_install
47} 52}
48 53
54do_install_append() {
55 install -d ${D}/${sysconfdir}/
56 install -m 644 ${S}/mdadm.conf-example ${D}${sysconfdir}/mdadm.conf
57 install -d ${D}/${systemd_unitdir}/system
58 install -m 644 ${WORKDIR}/mdmonitor.service ${D}/${systemd_unitdir}/system
59 install -d ${D}/${sysconfdir}/init.d
60 install -m 755 ${WORKDIR}/mdadm.init ${D}${sysconfdir}/init.d/mdmonitor
61}
62
49do_compile_ptest() { 63do_compile_ptest() {
50 oe_runmake test 64 oe_runmake test
51} 65}