summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/mdadm_4.1.bb
diff options
context:
space:
mode:
authorLiwei Song <liwei.song@windriver.com>2019-05-15 22:41:40 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-16 16:35:12 +0100
commit06abb513ecf33d7e8d1500fcfe13404d9f213e38 (patch)
treeac9f96bafb53cbec4d4fa92a86e80dc35ffb4472 /meta/recipes-extended/mdadm/mdadm_4.1.bb
parent15d400f1e2ca1e760c10a912617c6b38ebb43243 (diff)
downloadpoky-06abb513ecf33d7e8d1500fcfe13404d9f213e38.tar.gz
mdadm: install the systemd service through Makefile
The original mdadm service may include variable like BINDIR, It should use the real value of it, since the install method "install-systemd" in Makefile can easily do such work, so don't install it in bb file manually, use "make install-systemd" to install all the service of mdadm. (From OE-Core rev: be24f1dc995f7a996abfa551abea74f06de19ae6) Signed-off-by: Liwei Song <liwei.song@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_4.1.bb')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_4.1.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_4.1.bb b/meta/recipes-extended/mdadm/mdadm_4.1.bb
index ef5ddf55db..597faf787a 100644
--- a/meta/recipes-extended/mdadm/mdadm_4.1.bb
+++ b/meta/recipes-extended/mdadm/mdadm_4.1.bb
@@ -57,13 +57,15 @@ do_install() {
57do_install_append() { 57do_install_append() {
58 install -d ${D}/${sysconfdir}/ 58 install -d ${D}/${sysconfdir}/
59 install -m 644 ${S}/mdadm.conf-example ${D}${sysconfdir}/mdadm.conf 59 install -m 644 ${S}/mdadm.conf-example ${D}${sysconfdir}/mdadm.conf
60 install -d ${D}/${systemd_unitdir}/system
61 install -m 644 ${WORKDIR}/mdmonitor.service ${D}/${systemd_unitdir}/system
62 install -m 644 ${S}/systemd/mdmon@.service ${D}/${systemd_unitdir}/system
63 install -d ${D}/${sysconfdir}/init.d 60 install -d ${D}/${sysconfdir}/init.d
64 install -m 755 ${WORKDIR}/mdadm.init ${D}${sysconfdir}/init.d/mdmonitor 61 install -m 755 ${WORKDIR}/mdadm.init ${D}${sysconfdir}/init.d/mdmonitor
65} 62}
66 63
64do_install_append() {
65 oe_runmake install-systemd DESTDIR=${D}
66}
67
68
67do_compile_ptest() { 69do_compile_ptest() {
68 oe_runmake test 70 oe_runmake test
69} 71}
@@ -90,3 +92,5 @@ RRECOMMENDS_${PN}-ptest += " \
90 kernel-module-raid10 \ 92 kernel-module-raid10 \
91 kernel-module-raid456 \ 93 kernel-module-raid456 \
92" 94"
95
96FILES_${PN} += "/lib/systemd/*"