summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mc/mc_4.8.12.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-04-19 14:14:09 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-29 17:20:12 +0100
commit2b09f5ca682a50bf36086c7b3cc3a17760c9a3ed (patch)
treeb91be5e8cc4e0788cb0aaa39ac05734a24b31d31 /meta/recipes-extended/mc/mc_4.8.12.bb
parent936218e789277c6939535779c240d386e18c8891 (diff)
downloadpoky-2b09f5ca682a50bf36086c7b3cc3a17760c9a3ed.tar.gz
mc: update to 4.8.12
Add PACKAGECONFIG for two optional plugins (smb & sftp), both require other packages from meta-openembedded (From OE-Core rev: 64c44f02f1a320399e2f02aeaf83022bf83b69c8) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mc/mc_4.8.12.bb')
-rw-r--r--meta/recipes-extended/mc/mc_4.8.12.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-extended/mc/mc_4.8.12.bb b/meta/recipes-extended/mc/mc_4.8.12.bb
new file mode 100644
index 0000000000..b8971931d9
--- /dev/null
+++ b/meta/recipes-extended/mc/mc_4.8.12.bb
@@ -0,0 +1,51 @@
1SUMMARY = "Midnight Commander is an ncurses based file manager"
2HOMEPAGE = "http://www.midnight-commander.org/"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=270bbafe360e73f9840bd7981621f9c2"
5SECTION = "console/utils"
6DEPENDS = "ncurses glib-2.0"
7RDEPENDS_${PN} = "ncurses-terminfo"
8
9SRC_URI = "http://www.midnight-commander.org/downloads/${BPN}-${PV}.tar.bz2"
10
11SRC_URI[md5sum] = "a64c426364bfaee56b628f6c0738aade"
12SRC_URI[sha256sum] = "1054fcc27a488771cbe5b85d7c10135fa1cd1b7682a19930d44b51a023e39396"
13
14inherit autotools gettext pkgconfig
15
16#
17# Both Samba (smb) and sftp require package delivered from meta-openembedded
18#
19PACKAGECONFIG ??= ""
20PACKAGECONFIG[smb] = "--enable-vfs-smb,--disable-vfs-smb,samba,"
21PACKAGECONFIG[sftp] = "--enable-vfs-sftp,--disable-vfs-sftp,libssh2,"
22
23EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x"
24
25FILES_${PN}-dbg += "${libexecdir}/mc/.debug/"
26
27do_install_append () {
28 sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
29 sed -i -e '1s,#!.*python,#!${bindir}/env python,' ${D}${libexecdir}/mc/extfs.d/*
30}
31
32PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers-python ${BPN}-helpers ${BPN}-fish"
33
34SUMMARY_${BPN}-helpers-perl = "Midnight Commander Perl-based helper scripts"
35FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
36 ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \
37 ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \
38 ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \
39 ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \
40 ${libexecdir}/mc/extfs.d/uzip"
41RDEPENDS_${BPN}-helpers-perl = "perl"
42
43SUMMARY_${BPN}-helpers-python = "Midnight Commander Python-based helper scripts"
44FILES_${BPN}-helpers-python = "${libexecdir}/mc/extfs.d/s3+ ${libexecdir}/mc/extfs.d/uc1541"
45RDEPENDS_${BPN}-helpers-python = "python"
46
47SUMMARY_${BPN}-helpers = "Midnight Commander shell helper scripts"
48FILES_${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
49
50SUMMARY_${BPN}-fish = "Midnight Commander Fish scripts"
51FILES_${BPN}-fish = "${libexecdir}/mc/fish"