summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_5.07.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-06-24 09:22:00 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-25 10:23:37 +0100
commitb3a9e0eec0b937ca73bea1e4feca109c6a4e4ed9 (patch)
tree7f33528a414f386d58bf90f7bcdc2b12a53f20fe /meta/recipes-extended/man-pages/man-pages_5.07.bb
parent0c4cf4b7e15b31bd8be4a87a5b48992e7191ee43 (diff)
downloadpoky-b3a9e0eec0b937ca73bea1e4feca109c6a4e4ed9.tar.gz
man-pages: upgrade 5.06 -> 5.07
??file README update. (From OE-Core rev: e21cd56b026100b87f4d5ca5807bb7073d0b8cb3) Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/man-pages/man-pages_5.07.bb')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_5.07.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_5.07.bb b/meta/recipes-extended/man-pages/man-pages_5.07.bb
new file mode 100644
index 0000000000..04d0597b3d
--- /dev/null
+++ b/meta/recipes-extended/man-pages/man-pages_5.07.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Linux man-pages"
2DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
3SECTION = "console/utils"
4HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
5LICENSE = "GPLv2+"
6
7LIC_FILES_CHKSUM = "file://README;md5=207f70f56526417514ac46b6680e314f"
8SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/${BP}.tar.gz"
9
10SRC_URI[md5sum] = "193d9223e9c6dbe1d928eaaecc1f68db"
11SRC_URI[sha256sum] = "5ba58d7b2b9a8929903b1cf791ed4edf72ab225678d5ea0a6b80dc090080ac33"
12
13inherit manpages
14
15MAN_PKG = "${PN}"
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[manpages] = ""
19
20do_configure[noexec] = "1"
21do_compile[noexec] = "1"
22
23do_install() {
24 oe_runmake install DESTDIR=${D}
25}
26
27# Only deliveres man-pages so FILES_${PN} gets everything
28FILES_${PN}-doc = ""
29FILES_${PN} = "${mandir}/*"
30
31inherit update-alternatives
32
33ALTERNATIVE_PRIORITY = "100"
34ALTERNATIVE_${PN} = "passwd.5 getspnam.3 crypt.3"
35ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
36ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"
37ALTERNATIVE_LINK_NAME[crypt.3] = "${mandir}/man3/crypt.3"