summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_4.00.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-05-27 22:30:43 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-30 22:26:11 +0100
commit917ca4d70bc7724bbf9420da94fe846f79a7f7d5 (patch)
tree7f18a47e5929c7b90cd79168923fe67e92f0fab6 /meta/recipes-extended/man-pages/man-pages_4.00.bb
parent3ac8fb3f7b3b57db62129b527ab900b844ea43ae (diff)
downloadpoky-917ca4d70bc7724bbf9420da94fe846f79a7f7d5.tar.gz
man-pages: 3.83 -> 4.00
(From OE-Core rev: 1aeeb17a01c4a585b84ed52bd29d47e3e027d0b0) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/man-pages/man-pages_4.00.bb')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_4.00.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_4.00.bb b/meta/recipes-extended/man-pages/man-pages_4.00.bb
new file mode 100644
index 0000000000..121dd6c9e3
--- /dev/null
+++ b/meta/recipes-extended/man-pages/man-pages_4.00.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Linux man-pages"
2DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
3SECTION = "console/utils"
4HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
5LICENSE = "GPLv2+"
6
7LIC_FILES_CHKSUM = "file://README;md5=8f2a3d43057d458e5066714980567a60"
8SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/Archive/${BP}.tar.gz"
9
10SRC_URI[md5sum] = "c9bd70494ae18b19eb6be9c3845536ec"
11SRC_URI[sha256sum] = "6eea4583b8688c7d305b48d5908fa22700f57792617e4b1f3cd3766ddb520553"
12
13RDEPENDS_${PN} = "man"
14
15do_configure () {
16 :
17}
18
19do_compile() {
20 :
21}
22
23do_install() {
24 oe_runmake install DESTDIR=${D}
25}
26
27# Only deliveres man-pages so FILES_${PN} gets everything
28FILES_${PN}-doc = ""
29FILES_${PN} = "${mandir}/*"
30
31inherit update-alternatives
32
33ALTERNATIVE_PRIORITY = "100"
34ALTERNATIVE_${PN} = "passwd.5 getspnam.3"
35ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
36ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"