summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-db/man-db_2.11.2.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-01-15 13:20:54 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-16 10:42:07 +0000
commite55677116b7b6c9b9fa1c77b6cbc122ceffe21bd (patch)
treed3fe60e7c5ca1b4d7c6214fdb7fa16a214b985f5 /meta/recipes-extended/man-db/man-db_2.11.2.bb
parent2498587c310118337287954cd9b4a99e4310bb5a (diff)
downloadpoky-e55677116b7b6c9b9fa1c77b6cbc122ceffe21bd.tar.gz
man-db: upgrade 2.11.1 -> 2.11.2
Changelog: ========= Fixes: ------ * Fix compile and test failures when 'troff' is not 'groff'. * Fix segfault in typical uses of 'man' when 'nroff' is not installed. * Fix crash in 'mandb' when processing stray cats. Improvements: ------------- * Check for stray cats even if no manual pages in a given manpath were changed. (From OE-Core rev: f6ddfaac9e4957abfe9f1c8d336b4fd7b52a80f5) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/man-db/man-db_2.11.2.bb')
-rw-r--r--meta/recipes-extended/man-db/man-db_2.11.2.bb70
1 files changed, 70 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-db/man-db_2.11.2.bb b/meta/recipes-extended/man-db/man-db_2.11.2.bb
new file mode 100644
index 0000000000..ca0cb1a0e1
--- /dev/null
+++ b/meta/recipes-extended/man-db/man-db_2.11.2.bb
@@ -0,0 +1,70 @@
1SUMMARY = "An implementation of the standard Unix documentation system accessed using the man command"
2HOMEPAGE = "http://man-db.nongnu.org/"
3DESCRIPTION = "man-db is an implementation of the standard Unix documentation system accessed using the man command. It uses a Berkeley DB database in place of the traditional flat-text whatis databases."
4LICENSE = "LGPL-2.1-or-later & GPL-2.0-or-later & GPL-3.0-or-later"
5LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464 \
6 file://docs/COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://docs/COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8 "
9
10SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/man-db/man-db-${PV}.tar.xz \
11 file://99_mandb \
12 file://0001-man-Move-local-variable-declaration-to-function-scop.patch \
13 file://man_db.conf-avoid-multilib-install-file-conflict.patch"
14SRC_URI[sha256sum] = "cffa1ee4e974be78646c46508e6dd2f37e7c589aaab2938cc1064f058fef9f8d"
15
16DEPENDS = "libpipeline gdbm groff-native base-passwd"
17RDEPENDS:${PN} += "base-passwd"
18PACKAGE_WRITE_DEPS += "base-passwd"
19
20# | /usr/src/debug/man-db/2.8.0-r0/man-db-2.8.0/src/whatis.c:939: undefined reference to `_nl_msg_cat_cntr'
21USE_NLS:libc-musl = "no"
22
23inherit gettext pkgconfig autotools systemd
24
25EXTRA_OECONF = "--with-pager=less --with-systemdsystemunitdir=${systemd_system_unitdir}"
26EXTRA_AUTORECONF += "-I ${S}/gl/m4"
27
28PACKAGECONFIG[bzip2] = "--with-bzip2=bzip2,ac_cv_prog_have_bzip2='',bzip2"
29PACKAGECONFIG[gzip] = "--with-gzip=gzip,ac_cv_prog_have_gzip='',gzip"
30PACKAGECONFIG[lzip] = "--with-lzip=lzip,ac_cv_prog_have_lzip='',lzip"
31PACKAGECONFIG[lzma] = "--with-lzma=lzma,ac_cv_prog_have_lzma='',xz"
32PACKAGECONFIG[zstd] = "--with-zstd=zstd,ac_cv_prog_have_zstd='',zstd"
33PACKAGECONFIG[xz] = "--with-xz=xz,ac_cv_prog_have_xz='',xz"
34
35do_install() {
36 autotools_do_install
37
38 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
39 install -d ${D}/etc/default/volatiles
40 install -m 0644 ${WORKDIR}/99_mandb ${D}/etc/default/volatiles
41 fi
42}
43
44do_install:append:libc-musl() {
45 rm -f ${D}${libdir}/charset.alias
46}
47
48FILES:${PN} += "${prefix}/lib/tmpfiles.d"
49
50FILES:${PN}-dev += "${libdir}/man-db/libman.so ${libdir}/${BPN}/libmandb.so"
51
52RDEPENDS:${PN} += "groff"
53RRECOMMENDS:${PN} += "less"
54RPROVIDES:${PN} += " man"
55
56def compress_pkg(d):
57 if bb.utils.contains("INHERIT", "compress_doc", True, False, d):
58 compress = d.getVar("DOC_COMPRESS")
59 if compress == "gz":
60 return "gzip"
61 elif compress == "bz2":
62 return "bzip2"
63 elif compress == "xz":
64 return "xz"
65 return ""
66
67RDEPENDS:${PN} += "${@compress_pkg(d)}"
68
69SYSTEMD_SERVICE:${PN} = "man-db.timer man-db.service"
70SYSTEMD_AUTO_ENABLE ?= "disable"