summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp/ltp_20140422.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@enea.com>2014-04-26 16:51:25 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-29 17:20:12 +0100
commitc0df4f67a84c03b538fd3e8f46922a9af642d404 (patch)
tree03be25f6b472ded507bb139c0405789fd1217777 /meta/recipes-extended/ltp/ltp_20140422.bb
parent2b822a8458fe904626045c7e9e0291de806e31c1 (diff)
downloadpoky-c0df4f67a84c03b538fd3e8f46922a9af642d404.tar.gz
ltp: update version to 20140422
Update ltp version to 20140422 Removed two patches that already exist in the current version: 1. regen-makefile.patch 2. ffsb-remove-hardcoded-configure.patch (From OE-Core rev: d72430772400c7733da2339f238ab4ea69e48a8e) Signed-off-by: Maxin B. John <maxin.john@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ltp/ltp_20140422.bb')
-rw-r--r--meta/recipes-extended/ltp/ltp_20140422.bb82
1 files changed, 82 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp_20140422.bb b/meta/recipes-extended/ltp/ltp_20140422.bb
new file mode 100644
index 0000000000..bad9e6f147
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp_20140422.bb
@@ -0,0 +1,82 @@
1SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "http://ltp.sourceforge.net"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=216e43b72efbe4ed9017cc19c4c68b01 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://tools/netpipe-2.4/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \
15 file://tools/netpipe-2.4-ipv6/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \
16 file://tools/top-LTP/proc/COPYING;md5=aefc88eb8a41672fbfcfe6b69ab8c49c \
17 file://tools/pounder21/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
18 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
19 file://utils/ffsb-6.0-rc2/COPYING;md5=c46082167a314d785d012a244748d803 \
20"
21
22DEPENDS = "attr libaio libcap acl openssl"
23SRCREV = "f4c3bfe1eab51eb72caeb0f3336d2790c9a8bd1b"
24
25SRC_URI = "git://github.com/linux-test-project/ltp.git \
26 file://0001-Rename-runtests_noltp.sh-script-so-have-unique-name.patch \
27 file://ltp-Do-not-link-against-libfl.patch \
28"
29
30S = "${WORKDIR}/git"
31
32inherit autotools-brokensep
33
34TARGET_CC_ARCH += "${LDFLAGS}"
35
36export prefix = "/opt/ltp"
37export exec_prefix = "/opt/ltp"
38
39# ltp doesn't regenerate ffsb-6.0-rc2 configure and hardcode configure call.
40# we explicitly force regeneration of that directory and pass configure options.
41do_configure_append() {
42 (cd utils/ffsb-6.0-rc2; autoreconf -fvi; ./configure ${CONFIGUREOPTS})
43}
44
45# The makefiles make excessive use of make -C and several include testcases.mk
46# which triggers a build of the syscall header. To reproduce, build ltp,
47# then delete the header, then "make -j XX" and watch regen.sh run multiple
48# times. Its easier to generate this once here instead.
49do_compile_prepend () {
50 ( make -C ${B}/testcases/kernel include/linux_syscall_numbers.h )
51}
52
53do_install(){
54 install -d ${D}/opt/ltp/
55 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
56
57 # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual
58 cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases
59
60 # We need to remove all scripts which depend on /usr/bin/expect, since expect is not supported in oe-core
61 # We will add expect for enhancement in future
62 find ${D} -type f -print | xargs grep "\!.*\/usr\/bin\/expect" | awk -F":" '{print $1}' | xargs rm -f
63}
64
65RDEPENDS_${PN} = "perl e2fsprogs-mke2fs"
66
67FILES_${PN}-dbg += "\
68 /opt/ltp/runtest/.debug \
69 /opt/ltp/testcases/bin/.debug \
70 /opt/ltp/testcases/bin/*/bin/.debug \
71 /opt/ltp/testcases/bin/*/test/.debug \
72 /opt/ltp/scenario_groups/.debug \
73 /opt/ltp/testscripts/.debug \
74 /opt/ltp/testscripts/open_posix_testsuite/.debug \
75"
76
77FILES_${PN}-staticdev += "/opt/ltp/lib/libmem.a"
78
79FILES_${PN} += "/opt/ltp/* /opt/ltp/runtest/* /opt/ltp/scenario_groups/* /opt/ltp/testcases/bin/* /opt/ltp/testcases/bin/*/bin/* /opt/ltp/testscripts/* /opt/ltp/testcases/open_posix_testsuite/* /opt/ltp/testcases/open_posix_testsuite/conformance/* /opt/ltp/testcases/open_posix_testsuite/Documentation/* /opt/ltp/testcases/open_posix_testsuite/functional/* /opt/ltp/testcases/open_posix_testsuite/include/* /opt/ltp/testcases/open_posix_testsuite/scripts/* /opt/ltp/testcases/open_posix_testsuite/stress/* /opt/ltp/testcases/open_posix_testsuite/tools/*"
80
81# Avoid generated binaries stripping. Otherwise some of the ltp tests such as ldd01 & nm01 fails
82INHIBIT_PACKAGE_STRIP = "1"