summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsof/lsof_4.91.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex@linutronix.de>2021-09-08 20:01:20 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-11 18:41:37 +0100
commit094dcb2936e0157ccb5916b72fcf4d86a3d2e347 (patch)
treed2053266443cf2692dbbb0c552c6f4b1584e7a2f /meta/recipes-extended/lsof/lsof_4.91.bb
parentce636119aaede58b3b0b5fdf1f87dff7b42a0b7a (diff)
downloadpoky-094dcb2936e0157ccb5916b72fcf4d86a3d2e347.tar.gz
lsof: update 4.91 -> 4.94.0
Drop all custom sourcedir handling as the source is now a standard git checkout. (From OE-Core rev: 13965426b79e8c32f800a4317454321cfd2d06d1) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lsof/lsof_4.91.bb')
-rw-r--r--meta/recipes-extended/lsof/lsof_4.91.bb66
1 files changed, 0 insertions, 66 deletions
diff --git a/meta/recipes-extended/lsof/lsof_4.91.bb b/meta/recipes-extended/lsof/lsof_4.91.bb
deleted file mode 100644
index d7428ea2c4..0000000000
--- a/meta/recipes-extended/lsof/lsof_4.91.bb
+++ /dev/null
@@ -1,66 +0,0 @@
1SUMMARY = "LiSt Open Files tool"
2DESCRIPTION = "Lsof is a Unix-specific diagnostic tool. \
3Its name stands for LiSt Open Files, and it does just that."
4HOMEPAGE = "http://people.freebsd.org/~abe/"
5SECTION = "devel"
6LICENSE = "Spencer-94"
7LIC_FILES_CHKSUM = "file://00README;beginline=645;endline=679;md5=964df275d26429ba3b39dbb9f205172a"
8
9# Upstream lsof releases are hosted on an ftp server which times out download
10# attempts from hosts for which it can not perform a DNS reverse-lookup (See:
11# https://people.freebsd.org/~abe/ ). http://www.mirrorservice.org seems to be
12# the most commonly used alternative.
13
14SRC_URI = "http://www.mirrorservice.org/sites/lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_${PV}.tar.bz2 \
15 file://lsof-remove-host-information.patch \
16 "
17
18SRC_URI[md5sum] = "148ed410cb52e08c2adc0c60f480f11f"
19SRC_URI[sha256sum] = "c9da946a525fbf82ff80090b6d1879c38df090556f3fe0e6d782cb44172450a3"
20
21UPSTREAM_CHECK_URI = "https://github.com/lsof-org/lsof/releases/"
22UPSTREAM_CHECK_REGEX = "lsof_(?P<pver>.*)\.linux\.tar"
23
24LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar"
25
26S = "${WORKDIR}/lsof_${PV}_src"
27
28python do_unpack () {
29 if not bb.data.inherits_class('externalsrc', d) or not d.getVar('EXTERNALSRC'):
30 # temporarily change S for unpack of lsof_${PV}
31 s = d.getVar('S', False)
32 d.setVar('S', '${WORKDIR}/lsof_${PV}')
33 bb.build.exec_func('base_do_unpack', d)
34 # temporarily change SRC_URI for unpack of lsof_${PV}_src
35 src_uri = d.getVar('SRC_URI', False)
36 d.setVar('SRC_URI', '${LOCALSRC}')
37 d.setVar('S', s)
38 bb.build.exec_func('base_do_unpack', d)
39 d.setVar('SRC_URI', src_uri)
40}
41
42export LSOF_INCLUDE = "${STAGING_INCDIR}"
43
44do_configure () {
45 export LSOF_AR="${AR} cr"
46 export LSOF_RANLIB="${RANLIB}"
47 if [ "x${GLIBCVERSION}" != "x" ]; then
48 LINUX_CLIB=`echo ${GLIBCVERSION} |sed -e 's,\.,,g'`
49 LINUX_CLIB="-DGLIBCV=${LINUX_CLIB}"
50 export LINUX_CLIB
51 fi
52 yes | ./Configure linux
53}
54
55export I = "${STAGING_INCDIR}"
56export L = "${STAGING_INCDIR}"
57
58do_compile () {
59 oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}'
60}
61
62do_install () {
63 install -d ${D}${sbindir} ${D}${mandir}/man8
64 install -m 0755 lsof ${D}${sbindir}/lsof
65 install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8
66}