summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsof/lsof_4.85.bb
diff options
context:
space:
mode:
authorConstantin Musca <constantinx.musca@intel.com>2012-09-03 13:03:04 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-04 12:53:04 +0100
commit6a7eafbbd868675ae20dcaef4f6a7f53d25f6fd1 (patch)
tree333b4fe62d0102e1a1e7e327b629004b8f10eb1a /meta/recipes-extended/lsof/lsof_4.85.bb
parentb6e3b73602bd6a7e7d0954eca1d925572611c278 (diff)
downloadpoky-6a7eafbbd868675ae20dcaef4f6a7f53d25f6fd1.tar.gz
lsof: upgrade to 4.86
License checksum change due to the modification of the pre-compiled binaries section (no change in the license part). (From OE-Core rev: a0bfc2e014220ac97e7cd88c9579d5bcb2b1024b) Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lsof/lsof_4.85.bb')
-rw-r--r--meta/recipes-extended/lsof/lsof_4.85.bb54
1 files changed, 0 insertions, 54 deletions
diff --git a/meta/recipes-extended/lsof/lsof_4.85.bb b/meta/recipes-extended/lsof/lsof_4.85.bb
deleted file mode 100644
index de7ff680ca..0000000000
--- a/meta/recipes-extended/lsof/lsof_4.85.bb
+++ /dev/null
@@ -1,54 +0,0 @@
1SUMMARY = "LiSt Open Files tool"
2DESCRIPTION = "Lsof is a Unix-specific diagnostic tool. \
3Its name stands for LiSt Open Files, and it does just that."
4SECTION = "devel"
5LICENSE = "BSD"
6PR = "r2"
7
8SRC_URI = "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_${PV}.tar.bz2"
9
10SRC_URI[md5sum] = "102ee2081172bbe76dccaa6cceda8573"
11SRC_URI[sha256sum] = "49aa58e63539c45bada514a6a2e5a1c9f946ada1f4137dc9154cf4bf6054a1c1"
12
13LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar"
14S = "${WORKDIR}/lsof_${PV}_src"
15
16LIC_FILES_CHKSUM = "file://${S}/00README;beginline=645;endline=679;md5=e0108f7811919035515a97f872eb8ee2"
17
18python do_unpack () {
19 bb.build.exec_func('base_do_unpack', d)
20 src_uri = d.getVar('SRC_URI')
21 d.setVar('SRC_URI', '${LOCALSRC}')
22 bb.build.exec_func('base_do_unpack', d)
23 d.setVar('SRC_URI', src_uri)
24}
25
26export LSOF_OS = "${TARGET_OS}"
27LSOF_OS_libc-uclibc = "linux"
28LSOF_OS_libc-glibc = "linux"
29export LSOF_INCLUDE = "${STAGING_INCDIR}"
30
31do_configure () {
32 export LSOF_AR="${AR} cr"
33 export LSOF_RANLIB="${RANLIB}"
34 if [ "x${EGLIBCVERSION}" != "x" ];then
35 LINUX_CLIB=`echo ${EGLIBCVERSION} |sed -e 's,\.,,g'`
36 LINUX_CLIB="-DGLIBCV=${LINUX_CLIB}"
37 export LINUX_CLIB
38 fi
39 yes | ./Configure ${LSOF_OS}
40}
41
42export I = "${STAGING_INCDIR}"
43export L = "${STAGING_INCDIR}"
44export EXTRA_OEMAKE = ""
45
46do_compile () {
47 oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}'
48}
49
50do_install () {
51 install -d ${D}${sbindir} ${D}${mandir}/man8
52 install -m 4755 lsof ${D}${sbindir}/lsof
53 install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8
54}