summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsb/lsbtest_1.0.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2012-02-24 14:51:28 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-28 12:27:24 +0000
commit36a2f338f377d88cd2926bcfdcd2fa4207a49e8f (patch)
tree6fcbfef4b60a579864bcfd36279d3cf20bf666c7 /meta/recipes-extended/lsb/lsbtest_1.0.bb
parentc3a23ec304e750f82d8a98c2fc507478f03ab965 (diff)
downloadpoky-36a2f338f377d88cd2926bcfdcd2fa4207a49e8f.tar.gz
lsbtest: Add recipe for LSB tests and automate test
The recipe is used for LSB tests. The script LSB_Test.sh does the following things: - setup LSB testing environment - download LSB rpm packages with list file packages_list from remote - install the packages - execute LSB testing with profile file session - collect the results Install packages_list and session files into ${D}/opt/lsb-test. [YOCTO #1567] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lsb/lsbtest_1.0.bb')
-rw-r--r--meta/recipes-extended/lsb/lsbtest_1.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/lsb/lsbtest_1.0.bb b/meta/recipes-extended/lsb/lsbtest_1.0.bb
new file mode 100644
index 0000000000..d932c831f6
--- /dev/null
+++ b/meta/recipes-extended/lsb/lsbtest_1.0.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "automate test for lsb"
2SECTION = "console/utils"
3LICENSE = "GPLv2"
4PR = "r0"
5
6LIC_FILES_CHKSUM = "file://LSB_Test.sh;beginline=3;endline=16;md5=7063bb54b04719df0716b513447f4fc0"
7
8SRC_URI = "file://LSB_Test.sh \
9 file://packages_list \
10 file://session \
11 "
12RDEPENDS_${PN} = "rpm"
13
14S=${WORKDIR}
15
16do_install() {
17 install -d ${D}/usr/bin
18 install -m 0755 ${S}/LSB_Test.sh ${D}/usr/bin
19 install -d ${D}/opt/lsb-test
20 install -m 0644 ${S}/packages_list ${D}/opt/lsb-test/packages_list
21 install -m 0644 ${S}/session ${D}/opt/lsb-test/session
22 if [ "${TARGET_ARCH}" == "i586" ];then
23 sed -i -e 's/lsbarch/ia32/g' -e 's/targetarch/i486/g' ${D}/opt/lsb-test/packages_list
24 sed -i -e 's/targetarch/x86/g' ${D}/opt/lsb-test/session
25 fi
26 if [ "${TARGET_ARCH}" == "x86_64" ];then
27 sed -i -e 's/lsbarch/amd64/g' -e 's/targetarch/x86_64/g' ${D}/opt/lsb-test/packages_list
28 sed -i -e 's/targetarch/x86-64/g' ${D}/opt/lsb-test/session
29 fi
30 if [ "${TARGET_ARCH}" == "powerpc" ];then
31 sed -i -e 's/lsbarch/ppc32/g' -e 's/targetarch/ppc/g' ${D}/opt/lsb-test/packages_list
32 sed -i -e 's/targetarch/PPC32/g' ${D}/opt/lsb-test/session
33 fi
34}
35
36FILES_${PN} += "/opt/lsb-test/* \
37 "