summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsb/lsb_1.4.bb
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2012-09-05 17:31:04 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-10 13:01:48 +0100
commitd401258b819f6c74717a07cacd3103ca2a5a6583 (patch)
tree2e541b7d7e39d40e2dc6fcd9799378ac31e573e4 /meta/recipes-extended/lsb/lsb_1.4.bb
parent71749200ead901963e639c20a270c73050ba4a1a (diff)
downloadpoky-d401258b819f6c74717a07cacd3103ca2a5a6583.tar.gz
lsb: update version
Update package lsb version to be same with current lsb test suit version. Because when install the suit, it warns that need lsb version >= 3.0 at least. Drop the duplicated creating files under /etc/lsb-release.d. Provides directories /etc/opt and /var/opt that they are required by package lsb-dist-checker in lsb test suit. (From OE-Core rev: 973e615ab4ee325ab568f84e001a5724f4b0dd01) Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lsb/lsb_1.4.bb')
-rw-r--r--meta/recipes-extended/lsb/lsb_1.4.bb108
1 files changed, 0 insertions, 108 deletions
diff --git a/meta/recipes-extended/lsb/lsb_1.4.bb b/meta/recipes-extended/lsb/lsb_1.4.bb
deleted file mode 100644
index 513998cab8..0000000000
--- a/meta/recipes-extended/lsb/lsb_1.4.bb
+++ /dev/null
@@ -1,108 +0,0 @@
1DESCRIPTION = "LSB support for OpenEmbedded"
2SECTION = "console/utils"
3HOMEPAGE = "http://prdownloads.sourceforge.net/lsb"
4LICENSE = "GPLv2+"
5PR = "r4"
6
7# lsb_release needs getopt
8RDEPENDS_${PN} += "util-linux"
9
10LIC_FILES_CHKSUM = "file://README;md5=12da544b1a3a5a1795a21160b49471cf"
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/project/lsb/lsb_release/${PV}/lsb-release-${PV}.tar.gz \
13 file://init-functions \
14 file://lsb_killproc \
15 file://lsb_log_message \
16 file://lsb_pidofproc \
17 file://lsb_start_daemon \
18 "
19
20SRC_URI[md5sum] = "30537ef5a01e0ca94b7b8eb6a36bb1e4"
21SRC_URI[sha256sum] = "99321288f8d62e7a1d485b7c6bdccf06766fb8ca603c6195806e4457fdf17172"
22S = "${WORKDIR}/lsb-release-${PV}"
23
24do_install(){
25 oe_runmake install prefix=${D} mandir=${D}/${datadir}/man/ DESTDIR=${D}
26 mkdir -p ${D}${base_bindir}
27 mkdir -p ${D}/${baselib}
28 mkdir -p ${D}${sysconfdir}/lsb-release.d
29 echo -n "LSB_VERSION=\"core-4.1-noarch:" > ${D}${sysconfdir}/lsb-release
30
31 if [ "${TARGET_ARCH}" = "i586" ];then
32 echo -n "core-4.1-ia32" >> ${D}${sysconfdir}/lsb-release
33 else
34 echo -n "core-4.1-${TARGET_ARCH}" >> ${D}${sysconfdir}/lsb-release
35 fi
36 echo "\"" >> ${D}${sysconfdir}/lsb-release
37 echo "DISTRIB_ID=${DISTRO}" >> ${D}${sysconfdir}/lsb-release
38 echo "DISTRIB_RELEASE=${DISTRO_VERSION}" >> ${D}${sysconfdir}/lsb-release
39 echo "DISTRIB_DESCRIPTION=\"${DISTRO_NAME} ${DISTRO_VERSION}\"" >> ${D}${sysconfdir}/lsb-release
40
41 if [ "${TARGET_ARCH}" = "i586" ];then
42 mkdir -p ${D}${sysconfdir}/lsb-release.d
43 touch ${D}${sysconfdir}/lsb-release.d/graphics-4.1-noarch
44 touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch
45 touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-noarch
46 touch ${D}${sysconfdir}/lsb-release.d/graphics-4.1-ia32
47 touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ia32
48 touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ia32
49 elif [ "${TARGET_ARCH}" = "x86_64" ];then
50 touch ${D}${sysconfdir}/lsb-release.d/graphics-4.1-noarch
51 touch ${D}${sysconfdir}/lsb-release.d/graphics-4.1-amd64
52 touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-amd64
53 touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-amd64
54 fi
55 if [ "${TARGET_ARCH}" = "powerpc" ];then
56 touch ${D}${sysconfdir}/lsb-release.d/graphics-4.1-noarch
57 touch ${D}${sysconfdir}/lsb-release.d/graphics-4.1-ppc32
58 touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ppc32
59 touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ppc32
60 elif [ "${TARGET_ARCH}" = "powerpc64" ];then
61 touch ${D}${sysconfdir}/lsb-release.d/graphics-4.1-noarch
62 touch ${D}${sysconfdir}/lsb-release.d/graphics-4.1-ppc64
63 touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ppc64
64 touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ppc64
65 fi
66}
67
68do_install_append(){
69 install -d ${D}${sysconfdir}/core-lsb
70 install -d ${D}/${baselib}/lsb
71 for i in lsb_killproc lsb_log_message lsb_pidofproc lsb_start_daemon
72 do
73 install -m 0755 ${WORKDIR}/${i} ${D}${sysconfdir}/core-lsb
74 done
75 install -m 0755 ${WORKDIR}/init-functions ${D}/${baselib}/lsb
76 if [ "${TARGET_ARCH}" = "x86_64" ];then
77 cd ${D}
78 if [ "${baselib}" != "lib64" ]; then
79 ln -sf ${baselib} lib64
80 fi
81 cd ${D}/${baselib}
82 ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.2
83 ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.3
84 fi
85 if [ "${TARGET_ARCH}" = "i586" ];then
86 cd ${D}/${baselib}
87 ln -sf ld-linux.so.2 ld-lsb.so.2
88 ln -sf ld-linux.so.2 ld-lsb.so.3
89 fi
90
91 if [ "${TARGET_ARCH}" = "powerpc64" ];then
92 cd ${D}
93 if [ "${baselib}" != "lib64" ]; then
94 ln -sf ${baselib} lib64
95 fi
96 cd ${D}/${baselib}
97 ln -sf ld64.so.1 ld-lsb-ppc64.so.2
98 ln -sf ld64.so.1 ld-lsb-ppc64.so.3
99 fi
100 if [ "${TARGET_ARCH}" = "powerpc" ];then
101 cd ${D}/${baselib}
102 ln -sf ld.so.1 ld-lsb-ppc32.so.2
103 ln -sf ld.so.1 ld-lsb-ppc32.so.3
104 fi
105}
106FILES_${PN} += "/lib64 \
107 ${base_libdir}/lsb/* \
108 "