summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/logrotate/logrotate_3.9.1.bb
diff options
context:
space:
mode:
authorRomain Perier <romain.perier@collabora.com>2017-07-11 08:46:05 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-21 22:51:37 +0100
commit98d3a094d0d474303c3096d4c5d6223b7d5d7c3d (patch)
tree3b31fa83fdbd6b079cfd35547c5d79a0679e2a53 /meta/recipes-extended/logrotate/logrotate_3.9.1.bb
parentc2318ef416e13c3eaae14f395153ad97491a06bf (diff)
downloadpoky-98d3a094d0d474303c3096d4c5d6223b7d5d7c3d.tar.gz
logrotate: Bump to 3.12.3
This commit updates the recipe to the last upstream tag. Then, as the tarball no longer contains the pre-generated Makefile, inherit from autotools (From OE-Core rev: 72490b7a327867872987e63d340051c4980044b2) Signed-off-by: Romain Perier <romain.perier@collabora.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/logrotate/logrotate_3.9.1.bb')
-rw-r--r--meta/recipes-extended/logrotate/logrotate_3.9.1.bb71
1 files changed, 0 insertions, 71 deletions
diff --git a/meta/recipes-extended/logrotate/logrotate_3.9.1.bb b/meta/recipes-extended/logrotate/logrotate_3.9.1.bb
deleted file mode 100644
index 7c732122ba..0000000000
--- a/meta/recipes-extended/logrotate/logrotate_3.9.1.bb
+++ /dev/null
@@ -1,71 +0,0 @@
1SUMMARY = "Rotates, compresses, removes and mails system log files"
2SECTION = "console/utils"
3HOMEPAGE = "https://github.com/logrotate/logrotate/issues"
4LICENSE = "GPLv2"
5
6# TODO: logrotate 3.8.8 adds autotools/automake support, update recipe to use it.
7# TODO: Document coreutils dependency. Why not RDEPENDS? Why not busybox?
8
9DEPENDS="coreutils popt"
10
11LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
12
13# When updating logrotate to latest upstream, SRC_URI should point to
14# a proper release tarball from https://github.com/logrotate/logrotate/releases
15# and we have to take the snapshot for now because there is no such
16# tarball available for 3.9.1.
17
18S = "${WORKDIR}/${BPN}-r3-9-1"
19
20UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
21UPSTREAM_CHECK_REGEX = "logrotate-(?P<pver>\d+(\.\d+)+).tar"
22
23SRC_URI = "https://github.com/${BPN}/${BPN}/archive/r3-9-1.tar.gz \
24 file://act-as-mv-when-rotate.patch \
25 file://update-the-manual.patch \
26 file://disable-check-different-filesystems.patch \
27 file://0001-Support-system-dates-back-to-the-year-1970.patch \
28 "
29
30SRC_URI[md5sum] = "8572b7c2cf9ade09a8a8e10098500fb3"
31SRC_URI[sha256sum] = "5bf8e478c428e7744fefa465118f8296e7e771c981fb6dffb7527856a0ea3617"
32
33PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'acl selinux', d)}"
34
35PACKAGECONFIG[acl] = ",,acl"
36PACKAGECONFIG[selinux] = ",,libselinux"
37
38CONFFILES_${PN} += "${localstatedir}/lib/logrotate.status \
39 ${sysconfdir}/logrotate.conf"
40
41# If RPM_OPT_FLAGS is unset, it adds -g itself rather than obeying our
42# optimization variables, so use it rather than EXTRA_CFLAGS.
43EXTRA_OEMAKE = "\
44 LFS= \
45 OS_NAME='${OS_NAME}' \
46 'CC=${CC}' \
47 'RPM_OPT_FLAGS=${CFLAGS}' \
48 'EXTRA_LDFLAGS=${LDFLAGS}' \
49 ${@bb.utils.contains('PACKAGECONFIG', 'acl', 'WITH_ACL=yes', '', d)} \
50 ${@bb.utils.contains('PACKAGECONFIG', 'selinux', 'WITH_SELINUX=yes', '', d)} \
51"
52
53# OS_NAME in the makefile defaults to `uname -s`. The behavior for
54# freebsd/netbsd is questionable, so leave it as Linux, which only sets
55# INSTALL=install and BASEDIR=/usr.
56OS_NAME = "Linux"
57
58do_compile_prepend() {
59 # Make sure the recompile is OK
60 rm -f ${B}/.depend
61}
62
63do_install(){
64 oe_runmake install DESTDIR=${D} PREFIX=${D} MANDIR=${mandir}
65 mkdir -p ${D}${sysconfdir}/logrotate.d
66 mkdir -p ${D}${sysconfdir}/cron.daily
67 mkdir -p ${D}${localstatedir}/lib
68 install -p -m 644 examples/logrotate-default ${D}${sysconfdir}/logrotate.conf
69 install -p -m 755 examples/logrotate.cron ${D}${sysconfdir}/cron.daily/logrotate
70 touch ${D}${localstatedir}/lib/logrotate.status
71}